Time won't synchronize

The time in my Ubook always goes back to 2.5 hours delayed several hours after i click sync for the time and date. I emailed after-sale service and they advised me to change the time in BIOS. I had it changed in BIOS last night and shut down.
When I woke up this morning and opened by Ubook, the time and now including the DATE, remained during the time of my shut down. I tried again to shut it down nd open, and I confirmed that both time and date remains during my shut down!
It seems now that time and date stop at shut down!
Please advise what to do.

Usually, such problems are solved by disconnecting the battery for 1-2 minutes or by flashing the BIOS.
I would recommend continuing to contact the aftersale service if your tablet is under warranty.

Check and see if Services > “Windows time” is set to automatic.

Thanks. I already drained the battery whole night and started it the following day. No effect. Time won’t still synch. I heard some problems too with some people who updated their Windows 10. I don’t know if this is related since I updated already my Windows 10.
Anyway, I am waiting for the email reply of after-sale service. They were the ones who advised me to adjust it thru BIOS.
Thank you.

You mean, adjust the time thru thru normal Windows settings? Yes, I did.

Not synchronizing the time, rather: open Services through search, then scroll down to Windows time. One of my notebooks has the same time issue as yours, resetting Windows time to automatic has corrected the problem.

I did as you advised. Let me check tomorrow. I hope it will work.
Thanks a lot.

No, it did not work for my Ubook. Thanks anyway. Any new
advice will be welcomed.

Have you set the time zone manually? If not, try that.

Also, you might want to try to point to a different time server.

You can manually put in Google’s time server --> time.google.com

Hi. I did that last week and it didn’t work. But let me try it again.
Who knows, it may work this time.

Did not work. Thanks anyway.

Probably the main problem is the real time clock IC and perhaps settings in Windows can’t solve this.

By the way, every time I open my Ubook from shutdown, the time and date are the same as when i shut it down.
I noticed that
Any suggestions?

I noticed that the “Windows time” in the “service” is back to “manual” even if i turned it on to “automatic”.
Any suggestions?

Maybe but I don’t think it’s an IC issue.
I noticed that the “Windows time” in the “Service” goes to “Manual” even if i turned it on to “automatic”.

Try and run this script at startup https://gist.github.com/aivrit/fdfee71e969ba62670ed0b87c26f3aad#file-fix_windows_time-ps1

What is the file extension to run this code? I am hoping this will work. Thanks

$time = Invoke-RestMethod -Uri http://worldtimeapi.org/api/ip
$timezones = Get-TimeZone -ListAvailable
foreach ($timezone in $timezones) {
if ($timezone.DisplayName.ToString() -match $time.timezone.Split("/")[-1]) {
$current_zone = $timezone
if (!$current_zone) {throw “Could’nt find time zone. exiting.”}
Set-TimeZone -Name $current_zone.StandardName
Set-Date -Date (Get-Date -Date $time.datetime)

Copy and paste the script with Notepad, save without extension (not important). Create a shortcut (.bat) pointing to the location of this file to run it. C/P the .bat into the Startup folder, reboot. Good luck.

Hi. I put it in the startup folder with .bat.
Unfortunately, it won’t run or open. It opens only in a split second but won’t complete.
Any reason why? Thanks

Sounds like you have saved the script with the extension .bat and copy the file into Startup. You need to write a batch file, something simple like: run "c:\wherever your script file is located“ (quotation marks required), then copy this .bat file into Startup.