USB socket issue...difficult to insert plug!

On my front USB3 sockets, the gap below the ‘blue plastic’ is very thin and I really have to ‘lever’ a plug in! Anyone else had this?

Have you tried to reverse the plug and insert it?

Connectors on your PC seem to be correct, according to the promo image on HeroBox Pro-Mini ordenador-Products-Chuwi Official - Computadora portátil, Tablet PC con Android/Windows, Mini PC

It’s certainly not that! :roll_eyes:

They are the two USB 3 sockets. I just think the blue plastic pieces are slightly out of position, not leaving the usual gap for the plug to go in! It’s just a pity they’re not the USB2s, where the keyboard and mouse are not regularly removed’

Your message is confusing on two points:

  1. USB 3.0 is backwards compatible so any USB 2.0 will work on 3.0 socket, including mouse and keyboard.
  2. the picture you provided shows the 3.0 ports exactly how they should be, no difference between the two, and they are exactly how they are on my unit on all accounts.

So it’s not clear what the problem is. You either are confused or don’t know to explain it.

One note though: the Chuwi HeroBox have both those two USB 3.0 on the front upside down, so any USB device will be plugged face down. Maybe this confuse you and think they are messed up.

The point about the USB2 ports is that I would be using them for Keyboard and mouse, and therefore I wouldn’t be wanting to remove the cables regularly. So, not a problem once I’d inserted the cable.

As shown clearer in that 2nd image, there is a little ‘tab’ on the bottom edge of the blue plastic, and it makes the gap at the bottom too narrow to easily insert plugs, You really have to force them in with a slight levering action!

USB ports

I think Goomba is right. Again, if you still have this problem, please reverse the male connector and insert it. I am attaching a photo of the USB connectors from another machine, which are working correctly, so you can see that the ones on your PC are fine, but reversed, as Goomba says. So the solution would be to plug the connectors also inverted.

1 Like

Thanks for replying but as I showed in my last pictures, the blue plastic ‘guides’ on mine have that little bit of extra plastic in the middle, which reduces the gap for the metal casing of the plug to go in! (In effect it’s a ‘T’ shape) I can insert plugs, with a bit of force, but I’m just concerned that the blue plastic in the socket might snap, in time! It really doesn’t matter which way up they are, I can just rotate the cable! :wink:

In the image you have provided there seems to be enough room for the metal part of a USB type A plug, despite the “T-shape” of the blue tab. In any case, both connectors, plug and receptacle, must conform to USB specifications. If your USB plugs work fine with all USB receptacles except those on that specific PC, I suggest you to contact CHUWI technical support directly.
Captura de pantalla 2022-10-17 123126

I wouldn’t have started this thread if there was enough room! :wink: I was really just trying to find out if this was a general issue…clearly it’s not!

I had contacted support and all I got back was “No, when you pull it out, you can twist it left and right while pulling it out.” Didn’t address the issue of inserting the plug!

Where did that post go?

Interestingly, I can now see in the first picture that HectorR posted, which came from Chuwi’s own documentation, that those ports also have the ‘T’ shaped blue plastic. This can be compared with normal USBs, which are as shown on HectorR’s later illustration from a different machine.

In answer to the removed message:
1, No, it’s not something wrong with the cable I am trying to insert! I have tried it with several different cables and flash drives. (I can get them in, but it does require unusual force.)
2. My use of computers pre-dates USB, so I think I know when something is not quite right.

If your use of computers pre-dates USB then you should have known the explain in all the details and completely.

Look, I attached a picture I took just a minute prior to posting this message and the blue plastic tab inside my Chuwi HeroBox USB has the same “T” tab, and I can plug any USB as easy as in any other USB port, so the problem is not with USB on Herobox unit.