WiFi keeps disconnecting, only connects @ 2.4 not 5

Title says it all, for some reason my new HiPad Plus keeps disconnecting the WiFi and when it connects it refuses to connect via 5 instead using 2.4. Any thoughts? Anyone else having this problem?

1 Like

I just got my hipad plus, and I am having the same sale issue. Came with android 11, is it possible there is a bug fix

Yes, I have the same problem. Quite annoying, because 2.4 GHz WiFi has shorter range and is weaker than 5 GHz.

I’ve restarted/reinstalled multiple times and it connects to 5 Ghz at first then stops connecting and goes back to 2.4, and the 2.4 is super unstable and keeps getting dropped. :frowning:

Now recently I connected to a network that had the 2.4 and 5 SEPARATE connections and when I connected manually to the 5 it seemed to work and stay connected. So it seems to be when you have a SID that shares 2.4/5 that it has trouble.

Please please fix this, it’s incredibly frustrating and makes an otherwise good tablet almost totally unusable. It’s 100% a 2.4 connection issue.

I am experiencing this myself.

At home I only have 2.4 and connection is perfectly stable.

When connecting to a mixed 2.4/5 router connection comes and goes.

Temporary workaround maybe you name differently your 2.4Ghz and 5Ghz SSIDs?

Not ideal I know and cannot be done on every router but may work for some…

I’m having the same issue on both Tablets. Constant disconnection from my Mesh wifi and random reboots. This needs to get fixed or I will be sending both Tablets back and getting a different brand completely.

Try enabling reconnection on trusted networks in settings. I had the same issue but it’s now solved. Hope this helps!

Hi, i juste received my chuwi Hipad Plus and I have the same problem with the wifi.
How do you solved it ?
Otherwise i’ll have to return the product because it’s unusable.

I think it’s SOLVED!

I had the very same issue, was considering returning the tablet. But this issue is such a dealbreaker I was surprised that we were only a few people to report it.
Then I noticed my AP name was using both 5G and 2.4G. I needed to test with a more simple setup:
I created another AP with 2.4G only (no 5G on this AP name), and … well it’s been quite stable for the last few hours.
then I tried another AP with 5G only (no 2.4G), and it seems stable also.

So I think chuwi hipad plus just can’t handle correctly both 2.4G and 5G with the same AP name.

Well personally I can live with that for this price.

hth

lol Please don’t say it’s solved like that, you got my hopes up! We already know about the 2.4 and 5G combined part. Given that A LOT of WiFi Routers do this now (see Google WiFi/Nest), it’s still a HUGE issue as these Routers can’t split the signals. Also if you go anywhere where the signal isn’t split you’re basically screwed. :frowning:

P.S. I tether a lot when I travel and my Samsung ALSO can’t split the signal, so yeah…