AeroBook Plus 15.6" USB boot issue

Hi,
I am trying to install OSX on the new Chuwi AeroBook Plus, However I am not able to see the USB Sticks in both USB 3 ports when attempting to launch the boot menu (F7). The BIOS setup does show the USB sticks when I enter BIOS setup screen.

The Boot menu only shows Windows Manager. Is it because the BIOS only recognizes UEFI 32 bit?

Regards
Catcoool

1 Like

For Linux (64 bits), it recognizes the USB (fat32 formatted), but it did not load the kernel, so far, no way to install Linux.

Same here, can’t boot into Linux, I tried out 5 Distros of them, and all variations of linux bios setting recommendations.

I tried 3 distros Debian arch and EndeavourOs
in the middle of boot it simply poweroff completely :cold_face:

Thanks to the Chuwi Service! They send me an update for the so called Embedded Controler EC (bios side thingy idk). Afterwards Linux was able to Start (I first tried Mint). Here’s the link, or you go shure and contact the service CHEERS http://chuwi.mediafire.com/file/61ye47l1coaofla/EC-_Linux_installation_Aerobook_Plus_8G.rar/file

Anyone tried Danilo’s solution?
Is it working???

Thank you Danilo it work

1 Like

Hi, I saw this post in tonymacx86.

Maybe this would help?

Hi Danilo,

I also received this from Chuwi. Tried to create usb with windows 10 , plugged it in, hit f7, started from usb but then i got a lot of errors and the update utility says nothing. Asked chuwi for help again about 10 days ago and no response anymore. How did you do this? in the file name i see 8G, i have an i5 16GB, yours?

Hello! Did you have a cooling problem after installing this driver? Coolers practically do not rotate, do not react to the load. I could not cope with this, I decided to return to windows, but the problem migrated there too. Now I’m trying to solve it together with technical support, I’m waiting for a response from them.

Hi Ridder, I just followed the “readme” instructions…

Hi, I haven’t put attention on it, is there something new on your side?

Hi, did that too but i had installed a second SSD. When analyzing stuff i noticed disk errors while flashing. So i removed the second ssd and tried again and worked fine.
I could install Ubuntu and Linux Mint but unable to install Deepin 20

And we must use Deepin 20 :s I cant get past the first install screen. I get as second screen just the background and after minutes of waiting , black screen :sa:
Any ideas?

i did the EC, but what to do after it… i try to make a bootable usb with mint, kubntu… but it dosent start from usb… i use F7 on start, and select uefi partition1…

i try ubuntu and its start in GNU GRUB, but what to do now?

any help?

I have try to install manjaro but failed not have connection to installation screen, i do have checked the options on bios, if someone can help from chuwi

Hello! No progress on the part of tech support. It feels like every next answer is written by a new employee who has not read the previous letters: they ask the same thing, they do not answer questions. It looks like you have to give a damn about the warranty and carry it to a third-party service center.
On the one hand, it is of course good that the cooler no longer breaks down like abnormal and does not constantly change the rotation speed, but on the other hand, I understand that it simply stopped working.

Does your cooler work noisily?

I want to try can @Management confirm this EC update is safe and doesnt stop fan from functioning well