Aerobook Plus I5, 16GB Memory , Linux Installation fails

I have an Aerobook i5, 16GB memory version. And apart from the fact that the fan is behaving erratically, the WiFi reception is very poor, the laptop does work oke with Windows 10.

I tried to install different Linux Distros ( Linux Mint, Deepin, Manjaro,… ) , i am unable to even install any kind of Linux.

I had a response a few weeks ago from Chuwi support telling me that i needed to flash the EC with another version they sended me : “EC-Linux Installation Aerobook Plus 8G.rar”. Simply extract it, format a USB stick with FAT32 and name it WINPE, copy files to the stick and boot the laptop while holding F7

Everything oke but then it starts a Flash installation utility and doesnt do anything

My guess is thats for the 8GBMemory verion not for the 16GB. Or that an installation file is missing or wrong

Tried since then recontacting support, but nothing anymoore , it seems that support is dead

Can anyone else help me please?

Is there no one who can help? Who has the same issue like me on an I5, 16GB mem version?