[Bricked Tablet need bios] Chuwi Hi10 Plus Z8350 (build number 20170905) LQ64G42170905836

Hello, I have a Chuwi Hi10Plus with Z8350 CPU, build number 20170905, serial number LQ64G42170905836. I cannot find bios files anywhere for 20170905 build number. Can you send me the correct bios file for this build number? I really need it because my tablet is bricked. Already tried to flash with a bios file named: [P1D6_C189B_Hi10_plus_GC2355+2355_201703131454] provided to me but apparenly this isn’t the right one because after I completed without a problem the process with the clips and programmer to delete and rewrite bios etc as mentioned in the guide, in the end nothing happens when I tried to start my tablet. Thank you in advance…

Hi10 plus 1709 bios:
http://www.mediafire.com/file/35bd7g7hcw1k569/LQ64G421709.rar/file

Greetings. Thank you for your response. I tried to flash bios with the technique shown here https://www.youtube.com/watch?v=-K8Xif-6GUw , but after finishing all the steps and inserting this bios to the chip with the programmer tool, my tablet still won’t turn on.
(it was dead as a brick before I even try this method…
Story: it was in storage for a 3-4 months because of broken digitizer and after replacement I opened it and it worked for a day then I left it to charge and when I tried to turn it on the following day, bios logo would show 3-4 times as if it was rebooting or trying to boot several times then screen went blank. I left it to charge and that night I tried to turn it on but it wouldn’t open. Also after long pressing power button, power led which was on at that time went off and never turned on again. Ever since my tablet is dead I tried all the button pressing combinations that I could find but no luck.
Any ideas?? I am really disappointed because I thought it would work with the correct bios

Please copy your problem to service@chuwi.com.

Are you sure this is the correct bios? My tablet is dual boot. I don’t know if this make a difference?

this is the information of my tablet. pls send me the right bios. tablet won’t turn on
(screenshot was taken while it was still working)

is there a 20170905 bios file? The one you provided is a 201709 and it dont work

Based on past experience, providing a BIOS to a customer carries a high risk of turning a device into a brick. (Wrong operation or downloaded wrong version)

Actually,BIOS is only needed when the device cannot be turned on.

Therefore, The forum will no longer provide the customer with BIOS.

If necessary, please describe the reason for the need for BIOS (or describe the device problem) and send an email to aftersale@chuwi.com for processing.

My table is already bricked!!! Before I even try to revive it with the programmer tool !! I need the right bios for it to work. 201709 don’t work. Is there a 20170905 bios file??? Or any other possible bios file that I can try??? You can at least send it to me via PM…

Then here:
http://www.mediafire.com/file/35bd7g7hcw1k569/LQ64G421709.rar/file