Chuwi HeroBook Linux touchpad not support

How to make the touchpad work in Linux (ubuntu) on Chuwi Herobook? Ways on the Internet did not work. Make a Linux kernel driver / module for the touchpad for Chuwi HeroBook.

"Our products are designed for Microsoft Windows and are based on this operating system. Users are free to install third-party operating systems. However, we are unable to provide technical support for third-party systems

I recently purchased a Herobook and you’ll need kernel 5.5 or later to get support for the touchpad and wi-fi to work correctly in Linux. I installed Manjaro MATE Linux (had to temporarily use an Ralink USB wi-fi adapter for net access) and then used the Manjaro Settings Manager to install an “experimental” 5.5 kernel. Note that the currently stable 5.4 kernel sadly doesn’t support the touchpad or wi-fi at all.

The only issue left isn’t the touchpad, but the very slow speed of the otherwise working wi-fi driver in kernel 5.5. I tried a more specific driver from Github, but that was equally slow - hopefully this will be fixed in a future release.

Chuwi missed a trick not putting Manjaro on this, along with a SATA SSD (I added one myself) - it makes for an ideal low-end Linux laptop once you do that. Why is that pre-installed Linux laptops are almost all high-end and expensive - they certainly are from Dell, System76 and Tuxedo Computers!

1 Like

Chuwi herobook have rtl8723bu, need install driver in kernel. I completely solved the problem, I wrote an instruction, but it is in Russian, I think you can understand

That’s the Github driver (rtl8723bu) that I mentioned worked, but was just as slow as the “standard” (rtl8xxxu) driver that ships with kernel 5.5. It might be that whatever rtl8723bu code that at least gets the wi-fi to work has been upstreamed into the rtl8xxxu 5.5 kernel driver (at least with the Manjaro 5.5 build).

Running MX Linux ahs Without problems.