Front Camera Problem


After recent window update my front camera is really dark. It won’t auto adjust to the light it looks like. An suggestion on how to fix this issue? Is it a problem with camera?

Hi, @bso

What application do you use for camera?
If Microsoft Camera or Skype, these apps can tune brightness. As a first-aid.


I tried that.
Now the camera doesn’t work at all. I tried to update the driver but its not working. Any suggestions?


Is the front camera correctly recognized by Windows10 & BIOS ?

Device Manager->Cameras->front camera

If recognized correctly, it may work with Microsoft generic driver.

(but, you can download/install device driver for VID_0BDA&PID_5842. Here is my front camera’s event record. try at your own risk.)

Device USB\VID_0BDA&PID_5842&MI_00\6&14e718e7&0&0000 was started.

Driver Name: usbvideo.inf
Class Guid: {ca3e7ab9-b4c3-4ae6-8251-579ef933890f}
Service: usbvideo
Lower Filters: WdmCompanionFilter
Upper Filters:

i think its working?

where can I download the driver?

Your cameras seem to be recognized properly.

Drivers for them are Microsoft generic drivers (defined in [USBVideo.NT] section in usbvideo.inf (C:\Windows\INF\usbvideo.inf)), so no device specific driver is required.

If something errornous happened, related events must be recorded. In my case:

No error is recorded.
(I’m not sure what “requires further installation” means. Anyway, cameras prefer proprietary drivers to Microsoft generic driver, but can work with generic driver.)

proprietary driver can be found by Google search with “VID_0BDA” and “PID_5842”.
(Realtek USB2.0 PC Camera Driver for Windows10)
if you want, try at your own risk…

I tried installing the driver and it doesn’t seem to work.
Whenever I launch the Camera App nothing works. All I see is black screen, then after awhile I get a error message. Do I have to reinstall windows to fix this issue?

Do you remember the message?

Or, open Device property of the front camera and tap/click 1 then 2,

You see the all events related to the camera after adding snap-in, like this:

you can check the existence of any erroneous events there.

I don’t recommend you to reinstall because the origin of the error is unknown (moreover, reinstall is a quite inconvenient routine work). But… your back camera seems to work and the error started after Windows Update, there is the possibility to improve the situation. If you reinstall, I recommend “Reset this PC” from “Settings”->“Update and Security”->“Recovery”, USB boot is not required.

I looked through the log. It doesn’t seem like anything is off?
But the camera just won’t turn on. Also, in this process of fixing the front camera I have lost the back camera too now. I see that the devices is listed in the manager list.
So now I have lost both the front and back camera…

Thank you for the information.

Your cameras’ USB I/F is working properly. Device driver is installed correctly and working well. Only front camera does not get any image, may be blinded with something, or malfunctioned, I think.

You can reinstall Windows10. However regardless you do or not, I recommend you to contact CHUWI after-sale / support.

I’m sorry that I couldn’t help you.


If the camera worked at first, we must rule out a hardware failure.
As I understand that the problem is due to a driver update, you should try to reinstall the source drivers

Camera driver:

I had exactly the same problem…
This is how i fixed it:-

Create a new text document and rename it to EG “camfix.reg
right click on “camfix.reg” > select edit > copy the text below (in bold) and paste it into this file > save the file > double click on the file to add the entries in to the registry > restart your computer and then test the windows camera app now works.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows Media Foundation\Platform]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Media Foundation\Platform]

further info:


Thanks for all the help everyone.
I’ve tried all the suggested options and it still doesn’t work.
I’ve gotten to the point where the devices is sometimes not recognized. I have to Uninstall device, shutdown computer and turn it back on for the device to be recognized. Even after its recognized it doesn’t work, the camera app remains black and after awhile I get an error message.
Neither the front or back camera work now…
Is it possible hardware issue?