Herobook keeps bsoding

the laptop worked fine for 2 months, then after some updates it can’t load windows anymore and it’s just show bsod.

i tried reinstalling either linux or windows but the pc doesn’t load the bootable usb, i used rufus and tried either gpt either mbr partition scheme.
i use 32gb stick
what do you advise?

Try to do memtest. If everything is ok - try another usb drive.

i can’t access the pc, so i can’t do that test
basically the pc shows the usb and i can load it, but after i click for example “load ubuntu xx.xx” it just stays black.
also sometimes worked but stopped during installation
also sometimes doesn’t even load the first install screen of linux distros

i hope is not hardware problem :frowning:

ok i just saw it can be loaded on usb, ima try thanks

the test shows like 25k+ errors, what should i do?
should i take them from granted at 100%?

i also remember the pc shutting down randomly, so that may be a sign

You need to contact aftersale@chuwi.com and describe your problem. This is probably a hardware problem.