HeroBox limited to 100Mb ethernet

I’ve recently purchased the new HeroBox and it is surprisingly snappy. However, I’ve had difficulty with both wired and wireless networking running very slow. No matter what I’ve tried the network adapter is limited to 100Mb instead of 1000Mb and I have very poor wireless throughput on both 2.4 and 5Ghz networks. Wired I’ve tried a number of cables, switches, hubs and routers, all cat6 cables and 1Gb - 10Gb network gear with no effect. Wireless I max out at about 60Mbps 1 foot from the router while my cell phone will get 900Mbps.

I have tried different drivers, different bios settings, and a clean installation of Windows with no effect. While the experience of using the box is otherwise great, the slow networking is a deal breaker for my use case. Before I initiated a return is there something else I could try, or is this device really limited to 100Mb ethernet due to some hardware issue?

Update:

It is likely that the ethernet port is bad. When testing today I found that the connection is unreliable and now will not stay connected for more than a few seconds. Oddly, in Ubuntu it does register the wired connection as 1000Mb. Connecting the same Cat6 cable to a USB 3 ethernet adapter shows a connection speed of 1Gb and works correctly. As the proper ethernet port is nonfunctional I have initiated a return.

We will process your return as soon as possible. Sorry for the inconvenience

I’ve noticed the same issue with connection speed on two separate units. The connection speed is only showing 100Mb. I connected a usb-c hub with ethernet jack to the front usb-c port and was able to get 1000Mb speeds. It just seems to be the rear ethernet jack. I tried updating the drivers through windows update as well as a fresh install of Windows 10, but no luck so far. The network card shows up as a Realtek PCIe Family Controller, so Windows seems to believe it is capable of 1000Mb speeds. Is there perhaps a driver/firmware issue?

I have received a replacement device, and although the ethernet port is “fully functional,” this device is also limited to 100Mbps in Windows. I had run linux on the previous device and saw that it’s wired speed was reported as 1Gb but I did not actually run any tests. With the replacement device I have found that although rated at 1Gbps the HeroBox is incapable of throughput beyond 100Mbps in Linux indicating this is likely a firmware issue or hardware limitation. I am inclined to believe this is in fact a hardware issue that software will not resolve. Wireless performance on the replacement device is marginally better than the unit it replaced but is massively outperformed by literally every other wireless device I own. This is very disappointing as I really like the box otherwise.

After reading your experience, I just tried installing a copy of Linux Mint in the hopes that maybe I could get 1Gb on that OS, but it was still showing 100Mb while my USB C dongle had no issues showing 1Gb. I agree with you. This seems like a hardware/firmware issue. Perhaps a bios update could fix it? Hopefully Chuwi will get back with us soon with some helpful information.

I hope so as well. I had been planning to use this thing as a replacement for my rpi 4 as a VPN/file server. Being limited to 10% of my network speed on ethernet just kills it. For the time being I will continue using the ethernet adapter but ultimately I’ll likely return this replacement unit unless the advertised gigabit networking speed can be realized.

I have same networking problems. Bought Hero Box based on ChuWi’s claim that WiFi was “1300Mbps on the 5GHz” - Not true - WiFi chip used is 2014 tech and limited to 433 MHz. Likewise, “1 GB LAN” is limited to 100 Mbps. Limitation seems to be due to ChuWi either not wiring up all the pins on the board (GB needs all 4 pairs, 100Mb does not) or not enabling in BIOS. Same RealTek chip with same driver on another brand mini PC has no problem doing GB.
Also had to correct random Network disconnect issues on both the WiFi and wired LAN. This was due to Windows 10 Nov 2019 update changing previous defaults for various Energy Saving features.
Turning the WiFi and Realtek GBE driver energy saving off and also in Windows Power Plan resolved.
No more dropping.

Personally I have had no issues with network dropping out on my replacement device but that is a shame that it likely is a hardware issue for the wired port. I’ve tried multiple drivers/driver settings/bios changes with no luck. What kind of Wi-Fi speeds do you see? For me best case it tops out at around 65Mbps but I am unsure as to what I should expect given the specific hardware, just assumed it should be much faster. Last week I emailed Chuwi aftersale support for clarification on the bogus marketing specs for the HeroBox and received no reply.

If they don’t fix this issue very soon for GB LAN then it’ll be going back for a refund and i won’t be buying any Chuwi products ever again. Pretty pathetic to have a problem like this out of the gate and not be tested.

Can’t definitively say LAN is hardware issue, but my house router & switches are GB throughout. Most rooms were wired with CAT 5e or CAT 6 cabling. All jacks pass on RJ-45 test meter. Hero Box plods along at any jack in house and all other devices get full duplex GB at same locations.

Hero WiFi is out-dated Intel AC-3165 chipset - intro’d in 2014 and Intel’s own spec site says it maxes at 433 Mbps for 5GHz. When 10 ft from my AC-1900 router, it will hit that. Plugging in a USB WiFi dongle with a more recent Realtek chipset gets me 867 Mbps at same distance from router.

I planned to use the Hero Box as a HTPC and A/V storage server for the rest of the house. Streaming a single instance is not an issue, even with the crippled hardware. Transferring a TB+ of files would have taken 2-5 times longer and streaming to 2 or 3 devices at once not pretty.

Currently have both onboard WiFi and LAN networking “disabled” in Windows and am running on USB 3 to GB dongle which gives me full duplex GB and 2-3 times the file transfer speed of the built-in LAN or WiFi.

I also find it very interesting that this thread has been open so long without ANY feedback from ChuWi

I also cannot connect at gigibit. I sent email to the “VIP” customer service and they seem unaware of the problem so I sent a link to this thread.

Like I said - “interesting” customer service. I also posted a question before I bought my unit re: type of AC plug on power supply for unit sold thru Amazon (US?, EU?, Asia?). Got no response, but bought one anyway intending to return if not US. Finally did get answer over 3 weeks after I posted.

Between various hardware issues (defective LAN, old slow WiFi, overheating when SATA SSD installed) and no after-sales Support, I will not be recommending ChuWi to anyone.

Well, all that comes with a 200$ price tag. You can’t expect latest hardware and great support. Is there anything better you can get for 200$. I have Intel NUC but it came with four times bigger price.

Defective LAN should be replaced, that’s not something that customer should tolerate.

Actually, $200 is more than the $178 I paid for my last mini PC back in Feb 2018. It came with Win10, a 4c/4t Celeron CPU. Other than 4GB ram and no 2 1/5 bay, the other features were the same (full GB LAN, 433 Mb/s WiFi, 3 USB 3.SDxc, HDMI) Did upgrade with a larger M2 drive, but only because I used it for a video server. Today WD Blue 500GB M2 goes for $65. Given 2+ years inflation I call it about even.

You miss the point - ChuWi is advertising and selling the Hero Box claiming GB LAN, 1300 Mb/s 5GHz WiFi and Silent Fanless cooling that works (80C+ temps and thermal shutdowns under load is not working). That and the failure to respond to the issues raised here in 3 weeks is MUCH LESS than I expect.

I’m also here to report that my herobox is also getting 100 Mbps running the native Windows 10 installation. I even upgraded the Ethernet driver to the latest via the manufacturer website and still did not get 1 Gbps. I tried to force 1 Gbps on the herobox and my managed switch and the herbox went unresponsive.

I truly believe this is a firmware issue on the herobox, but we must wait for the Chuwi team to get back to us. For whatever reason I do remember seeing that due to the lunar new year they will be out until sometime in February (don’t remember the exact date) which may explain the no responses to ticket requests or in this forum.

@Chuwi - please provide the latest on these requests. It’s clear that it is not a hardware issue… unless we’ve all been lied too about the gigabit capability on the Ethernet port.

I guess it’s always a lottery with Chinese low budget products. You never know what you will get.

Regarding their advertising, I’ve stopped paying attention to it a long time ago. Most of their companies still don’t know what is after sale support and how to honestly describe their products. Like ad that N4000 can encode 4k, I don’t think so. But then again their prices are much lower then US or EU products.

I already own three Chuwi laptops and I am pretty happy with them, but some of them had some flaws, like provided cooling solution which I was able to upgrade/solve for just 5$.

I think I will pass HeroBox, heating issue and not working 1gb port is a problem for me. Now I am looking Beelink mini PC. I would like to buy Chuwi mini PC, but until they solve this problems and learn how to provide precise information about their products and a decent support I will skip them.

1 Like

Been using a Beelink AP34 with 4c Apolo Lake Celeron for 2 years. Still running great, but I did stick a 256GB M2 in it. 64 GB eMMC it comes with is a joke.

After some top off inspection, looks like Chuwi won’t be fixing my slow WiFi, slow LAN or heating issue

  1. Intel WiFi module is AC3165 / 433 Mbps Max and not socketed - no swapping for up-to-date WiFi module.

  2. GB LAN takes all RJ-45 4 wire pairs connected - 100Mbps LAN only takes 2 pairs. To my old eyes, it looks like there are only 2 pairs of traces on the motherboard between the RJ-45 port and the SG243 SMD transformer chip. This would limit the GB Realtek RTL-8168/8111 GBE chip to 100 Mbps no matter what driver you use or how good your cables are.

On the official ChuWi Hero Box page Product page
They show a pretty image of the HB with the top ghosted so you can see the elaborate finned CPU cooler inside
ChuWi phony CPU cooler
With claims of “Scientific Design-Effective Heat Dissipation” and “Continuous 4-hour in use, it stays 34℃”
BS! Their Scientific Design is a flat aluminum plate 3mm thick over the CPU. No fins, no science, no proper airflow just a small chunk of AL. No wonder it can’t take extended running - ChuWi’s idea of “Continuous 4-hr use” must mean turning it on and only letting it idle.

1 Like

Thank you for this useful info. I guess I will try my luck with Beelink U55.

So there is no big finned aluminum cooler?? Jeez! Can’t understand why they do things like this. It’s not like that finned alu cooler costs 50$.

Can you remove their flat alu cooler and replace it with a better copper or finned alu?

“Can you remove their flat alu cooler and replace it with a better copper or finned alu?”

Existing plate does have mounting screws to MB, but gamble which will be stronger, mount of CPU to it’s socket, or whatever glue/thermal compound was used. Pull or twist on AL plate and you may bork the CPU pins/BGA and have a cool brick. Probably better to leave the plate in place and attach an big finned cooler to it with some good thermal compound. I have big selection of passive cooling on old video cards, but still would have to deal with the problem of getting air in & out of case. Lots of existing holes, but all small & in wrong place - would need to cut the top open for clearance and to let hot air out…

For now, I can still use it for another HTPC by throttling the Win10 CPU power profile to 85% which limits max CPU speed to 1 GHz. Still fast enough to play HD video over network and keep temps under 70C after 90 mins playback. Too bad - already had 2 other brand mini HTPCs that can do that. Really bought this to put a 1TB SSD in and use for my file server also.