HeroBook lost network settings and now no wifi

I just purchased a new HeroBook and after doing updates the network adapter, settings, and connectivity to wifi is gone. Has anyone else experienced this? I am in the middle of reinstalling so I am in hopes that will correct the problem, but not sure what to do if it happens again?

Tell me your serial number

Hello,
I believe the information you are asking for is:
HeroBook64G191104313

If that is not the correct info, please inform me where to find that? I checked the underside and this is all I could find,

You should reinstall the driver.

Hello,

I will give this a try, hopefully I will not have to contact you again.

Thank you for your assistance.

Hello,
I followed the instructions to the letter but it did not give me the screen that was shown in the instructions. It did not reinstall anything or fix the problem. The only network connection that is shown is the Bluetooth. I have attached a photo of what the HeroBook did when I attempted to boot from the USB. The screen is nothing like what the instructions showed. Uncertain as to what to do, I am having second thoughts about purchasing this machine.IMG_3509 I would really appreciate some useful help in dealing with this issue.

I also noticed that the files were not the same, there were some missing. If you would like to see what files I received from the download I can give a list. If there are missing files then perhaps that will resolve the issue? I noticed there was another post somewhere that also described the same issue but with a different model. I have done a reinstall of Windows but now since I cannot go online my copy of Windows is not activated & I cannot activate it since I cannot go online,

This screen that shows is because you chose a different boot at the start, marked Del instead of the pendrive

If you can load Windows, go to startup, configuration, update and security, recovery, reset this pc. put the charger and let it finish, without turning off even if it seems to have stopped

When I tried to follow the instruction document, when I clicked on the boot manager button the USB was not an option, the only way to get to the USB was to click on the File option. See the attached photo of what option I had when I followed the instruction document. As you can see it only gave me the Windows boot option.

Now in the process of resetting, hoping that will resolve the issue.

Hello, after attempting the fixes listed here - which did not work. I attempted to reset Windows but that also did not fix the problem. Now my copy of windows is not activated because I cannot go online to register. Could you tell me what the complete list of network adapters is? That way I can compare with what is currently on the HeroBook, perhaps that will give a better understanding of what needs to be done to correct this problem. I am a little concerned since I have not even been able to use the machine since it was delivered. I am also getting ready to go to a conference & also visit my family, I fly this coming Friday morning and will be gone for 4 weeks. I purchased the HeroBook to take with me, but it appears that it will not be do-able. I would appreciate someone getting back to me sooner, rather then later.

Thank you

It’s time to copy your problewm to service@chuwi.com.

Hello,

I have done that, but the initial reply was not so helpful. I have attached a photo of the Network Properties that the HeroBook now has. Clearly there is a problem since it only recognizes the Bluetooth and nothing else. So the machine no longer sees the WiFi adapters or network card. This has been the problem since the first day that I received the HeroBook after it attempted the first couple updates. No matter what I have done, it has not been resolved. Aftersales gave the reply of:

The system is the version of RS5. At present, the latest version of Microsoft Windows system is RS6 1903. If it is linked to WIFI, it may automatically download the update package and download the update package for a long time, so it

always appears in the interface waiting for you. The first time to enter the system in the wifi link interface is recommended to skip, do not connect wifi, enter the system after connecting wifi

or you were able to resolve the problem by turning off my router then starting the pc thus by-passing the Microsoft set up.

Regards

Alisa

So here is my frustration point - I cannot connect to WiFi, I cannot update anything, I cannot seem to get the HeroBook to go back to the original state and none of the suggestions I have received have provided a solution to the problem I have sat with for 4 days now. I am sad to say that it would seem I have wasted €154 for nothing & this does not make me happy. My hope is the photo will help in making the problem clearer. Any further suggestions are welcome to resolve this problem.

Hi,

I bought the Herobook as well. Here are a few things to try:

  1. The Wifi on the Herobook can ONLY connect to your router using 2.4 ghz. It will NOT operate at 5 ghz. I had to go into my wifi router and enable 2.4 ghz mode. A manual for your wifi router is usually online.

  2. I assume you have downloaded the drivers that match your serial number? Its a "Realtek 2.4 ghz Wifi Driver.

  3. Click Start, hold down “shift key” while clicking on “Restart” then after restarting click “7” or “F7” and system should restart normal.

  4. Go into “Device Manager”, click on Herobook at the top until highlighted, then click “Actions”, the click “Scan for Hardware changes…”

  5. Show up yet?

  6. Under network, look for “Realtek Wifi”. If still not there, click “add device”. Look in “have disk” and add driver.

  7. Go to Wifi Settings and add Wifi Setting. Look in your Wifi Router for “Gateway IP” its the same as the IP you put in to get to your router. Usually 192.168.0.1 or 192.168.1.1. You should be running DHCP. In Windows Wifi settings should be similar to:

DHCP (not static)
Gateway IP: 192.168.0.1 (put yours here)
Subnet: 255.255.255.0 or /24
DNS 1: 192.168.0.1 (put your Gateway IP)
DNS 2: 8.8.8.8 (if it asks)
Remember only 2.4 ghz not 5 ghz

Hope this helps… message me and Ill help you further.

In addition…

I downloaded the Chuwi drivers and unzipped them into a folder. Well… windows doesnt like downloaded files if it doesnt come from Microsoft so they put a BLOCK ON YOUR DRIVER FILES!!!

Just highlight a driver file, open “properties” and you will see 3 boxes at the bottom (“Read only”, “Hidden” and “UNBLOCK”!

Check "Unblock, “Apply” and “OK”. Then go to Device Manager and update the Drivers… otherwise the laptop wont “see” the driver cause it was Blocked.

You have to unblock files… ONE AT A TIME.

Ive searched online to DISABLE the blocking but have not found a way.

This has nothing to do with unsigned drivers either… the shift, restart, F7 trick doesnt help.

Why doesnt Chuwi have an installation program for the drivers???

Hello Shane yesterday i faced the same problem with you. After updating all my drivers with the help of driver booster program i lost the wifi connectivity completely. I managed to fix that after many hours and i would like to share the solution with you before you do something you are going to regret later like smashing your laptop. I fully dissasembled the laptop and located the wifi chip and checked what is the realtek chipset this motherboard carries. The chipset is RTL8723BU but after doing a lot of research for this driver i couldnt find the right installation file to make it work. The solution to this problem is to follow step by step the instructions to flash again WINDOWS 10 like i did but it is very important to do exactly what you read at the instructions. I succesfully flashed the windows installation file and my wifi antenna worked again like a charm. I have also taken a full driver backup of my herobook and in case you fail again installing windows 10 i can share a link with all the drivers of Herobook. I hope i helped you and you are free to ask me anything.
All you need to do is to download from here


all the eight parts and then decompress them into one single file you can use winrar to decompress the files into one. Then you follow the steps as shown in the instructions document!

Driver WiFi Driver WiFi Chuwi HeroBook Instal-Restart :wink: