Hi10 Air only read 2Gb ram the other 2Gb dissapeared

following the factory reset of my HI10 Air, the bios only reads 2gb of ram instead of 4. Has anyone found themselves in the same situation? And if so, how can it be resolved?

A thousand thanks

If you send me your Serial number maybe i can give you the original files so you can install everything

OK, perfect Hi10 airQ64G19011623

I hope to solve it because today it happened that it doesn’t start anymore

A thousand thanks

Here are the file




Thanks for your prompt response, but I can restore everything since the device no longer turns on, if I insert a pen drive it flashes as if it were charging the battery but nothing at all when starting up

I have serious problem, pendrive is active tablet total black display
I don’t know!!!

@manonegra222 do you have an idea of how to help with this?

no I’m sorry I’m waiting for a response from someone, obviously if there is a method to restart it

You should check if, even if the screen does not turn on, the system starts. To do this you must connect the tablet to an external screen through the HDMI port or USB C if it is a full port. If there is no image on the auxiliary screen we may think that the system does not start and we will try to find another solution

the screen is all black with an hdmi splitter I tried to start the tablet but to no avail😔

Put the charger on for 24 hours as it is possible that the battery is at its minimum levels and may not be able to turn on the tablet. Observe if the charging LED flashes and if it becomes fixed when charging is finished.

Hi, I have a similar problem. I was turning on my Windows tablet and the word Chuwi appeared with the Windows loading ball, it turned off and on again in a loop. Until it turned off and never turned back on. The screen remains black. With HDMI you can’t see anything, but when the keyboard is connected for a few seconds the LED comes on, but after about 3 seconds the LED goes off I left it charging for more than three days but not even the charging LED comes on. I tried holding for 30 seconds, releasing and pressing for 3 seconds but nothing So I took it apart, disconnected the battery and reconnected it but nothing. Some advice?