Hi10x Could not turn on - can charge - no chuwi logo

Hi, I have a hi10x. After shut down, it does not turn on again.


  1. Press power button
  2. Red LED turn on for 0.5 second and goes dark (Keyboard light-power up)
  3. No Chuwi logo, PC does not boot up
    Video (without charger): https://1drv.ms/v/s!Am83SkDZ9PUBhcR0xSiY3tIy1BR5cA?e=t0409x
    Video With charger: VID_20240121_104111.mp4

What is working:
→ Able to charge (Red LED showing)

What have I tried (not working):

  1. 3 short press, 1 long press
  2. Press and hold for very long time
  3. Battery reset - pull battery out, wait for 1 - 2 hours and put back on

What could be the issue? What should I do next?

1 Like

I really see that you have read the forum and used the main methods to recover your tablet. You just have to check if it’s still in the same situation without the keyboard connected because it could be that the keyboard drains the battery.
Try again the routines of pressing the power button with the charger on and without the keyboard and add one more, press the power button for 30 seconds with the charger on.

Yeap, tried without the keyboard. Still not starting. Even with power supply, also not starting. Upon pressing the red light show for 0.5 sec and it went off. No chuwi logo, nothing.

I have seen you wrote to us, and my colleagues told you that unfortunately as it is quite old we dont have those replacement parts, if it was for the Motheboard. I have Checked in Shenzhen warehouse and we still have some stock,in case you wanted to buy the same model, but my colleagues they me the ones we have, are customized for some companies, so cannot sell to the general public. have different configuration and so…
I am sorry.

Lets see if another person has any other idea