[HiBook Pro] [Official Version] Chuwi HiBook Pro Windows, Android, Bios, Driver Download

[Official Version] Chuwi HiBook Pro Windows, Android, Bios Download:

Chuwi Dualboot HiBook Pro Android:
http://www.mediafire.com/file/rn … ook_Pro_Android.rar

Chuwi Dualboot HiBook Pro Windows - 6 parts (rar):

(Due to Windows file too large, i divide Windows into 6 parts. Every part is about 1 G.)

Chuwi Dualboot HiBook Pro Bios:
http://www.mediafire.com/file/zo … ok_Pro_Bios_231.rar (version: I1D6_C109K.231)

Chuwi Dualboot HiBook Pro Bios:
http://www.mediafire.com/file/2b … _I1D6_C109K.234.zip ( version: I1D6_C109K.234 )

Chuwi Dualboot HiBook Pro Driver:
http://www.mediafire.com/file/xk … ook_Pro_Drivers.zip

Chuwi HiBook Pro Z8350 Download:
(used for serial number after PQ64G45170102501)

Android (Z8350):
Chuwi HiBook Pro Android Z8350:
https://chuwiinnovationtechnolog … 1boi9gxln7fq3v7stsh

Windows (Z8350):
Chuwi HiBook Pro Windows Z8350:
https://www.mediafire.com/folder … k_Pro_Windows_Z8350

I cant install the bios update … failed by - Image type IA32 is not supported by this x64 shell…

What happened to your equipment? Why do you need bios?

Core Version: 5.011
Compliancy: UEFI 2.4; PI 1.3
Project Version: I106_C109.222 x64
Build Date and Time: 04/02/2006 14:16:05
Microcode: 35f

I think this is the old one with wifi problems and i want to fix it with the new one …
so how can we fix the “Image type IA32 is not supported by this x64 shell” problem?

PhoneFlashTool does not recognize HiBook Pro of DNX FASTBOOT MOOE in Android recovery. Do I need a particular version?

Is there a way to recover Android without using Tool?

You must have installed Android drivers for the flash tool for the tablet to be recognized. Google them

manonegra222,Thank you for your response.
The driver seems to be set up with the tool. Can you see the attachment?

The problem was solved by replacing the USB cable with an approved product.
Thank you for the explanation.
HiBook Pro is an old product, but the concept is good. Use it carefully. I hope the Android version goes up.

I’m glad you were able to fix the problem. Sometimes the USB C connector, if it is not long enough, does not make good contact on the tablet since the connection is quite deep.
Indeed the tablet is already years old, but I still use a Vi10 Pro from 2015 with a battery life of more than 6 hours.
Unfortunately, for reasons beyond Chuwi, the Android version cannot be updated since Intel stopped developing Android drivers for its Z8350 or Z8300 processor, which is the one found on your tablet.

Hello, I’ve updated Windows 10 to last version 20H2 on my Chuwi HiBook Pro (with Z8300 CPU).
After the update, the MicroSD Reader stopped working and Device Manager shows a “Code 10” error. However, on Android everything works. It seems to be a driver incompatibility with the last Windows 10 update.
I’ve tried each one driver of the zip archive in the first post, but no one was intended for the MicroSD Reader.
Can you send me a driver for the microSD reader compatible with the Windows 10 20H2 version?

Is the latest Win10 in HiBook Pro a driver bug? Isn’t it a solution to extract the original driver before updating?

Is there anyone using the Android side with Android x86?
I’m investigating a solution for the touchpad not working.


Could you please send Android download link for HiB PQ64G45160600943

Thank you

Try this: HiBook Pro Android

1 Like

Thank you.
How can I load this image file to my CHUWI HiB?
Thank you.

@manonegra sure can tell you

You must to use Microsoft flash tool but if you don’t use a file flash .“no erase all” you will have to install Windows again

I’m Sorry, your tablet has Windows.

You need to use the Windows official rom.

Please, write here you serial number.