Mi network adaptor doesnt work

I bought a HEROBOX to install home assistant. After installation, my program doesn’t detect the network card. It’s a Debian system. Can you help me find the linux drivers for it? Thank you!

hello, we don’t have linux driver, thank you

That’s à shame.
Could you please tell us what is the chipset used for the ethernet. We may be able to find the relevant driver.

Is the Linux box check somehow ?

Hi,
I was about to install debian 11 to test for the same problem.
Which version have you try 10 or 11 ?
Have you try debian image including non free firmware ?
https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/

Hi Manuel,
You have to upgrade your debian Kernel.
follow the steps to do it here :
Install/Upgrade Linux Kernel 5.16 on Debian 11 Bullseye
I’ve done it and the network adaptor is detected and internet works.
Have a nice day

Hi I have the CHUWI Herobox mini pc (the one with Intel Celeron J4125), I tried to put Debian 11 but it always stops at this part:

Unfortunately, even trying to install debian testing (which if I remember correctly has the 5.16 kernel does not solve anything, the problem remains!).

Consequently, I am unable to go to the Internet, neither via wifi, nor via Ethernet.

How can I solve? otherwise if I cannot install Debian 11 I will have to return the product.

I tried again this morning to reinstall with debian testing, and this time trying again to choose NO as the setting once I get to that screen; then it continued (while yesterday it kept returning to that screen with whatever choice I made).

hi Mike,
you cannot solve it.
just say NO and continu.
I got the wifi working with any desktop, but no wifi with server only.
see my post here
https://forum.chuwi.com/t/herobox-cannot-detect-ethernet-linux-mint/31387/8?u=ziorg

have a nice day