Herobox cannot detect ethernet linux mint

Hello, i just installed linux mint, i have no idea of linux, and i cannot get ethernet. WIFI is working
It was working with windows so the hardware is OK.
what should i do?

Same problem here with Ubuntu, I have WiFi but no Ethernet, showing as UNCLAIMED with lshw.

If I can’t sort it quickly I’ll just return to Amazon and swap for something different.

Was thinking of doing the same.
I didn’t try yest installing debian 11 to test for the same problem.

Any idea of fanless equivalent mini pc ?

No, but I’ll take a look later and post here, if you find anything let me know here too.

Hey guys, i tried later Mint cinnamon (edge) with the latest kernel, and then ethernet worked.
Now im with ubuntu because i feel it faster, but ethernet working in both, only mint need to be in edge version.

That’s interesting, can you post the output of lshw -C network
What module is loaded against it?

Also what is the interface shown as in ifconfig?

after installing debian 11, still no ethernet,
Updating the kernel to the last one 5.16 and bingo its working

lshw - C network gives :slight_smile:

description: Ethernet interface
produit: Ethernet Controller I225-V
fabriquant: Intel Corporation
identifiant matériel: 0
information bus: pci@0000:02:00.0
nom logique: enp2s0
version: 03
numéro de série: 84:47:09:0b:77:88
taille: 1Gbit/s
capacité: 1Gbit/s
bits: 32 bits
horloge: 33MHz
fonctionnalités: bus_master cap_list rom ethernet physical 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=igc driverversion=5.16.0-5-amd64 duplex=full firmware=1079:8770 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
ressources: irq:23 mémoire:c1300000-c13fffff mémoire:c1400000-c1403fff mémoire:c1200000-c12fffff

Update here, I upgraded to Ubuntu 20.10 and everything is now fine, Ethernet NIC works, wifi, sound etc