No data transfer to Hipad X


I have recently bought a new Hipad X with the intention of using it as a dedicated drone controller for my DJI device. However, upon trying to connect it to the controller via USB C cable, it will not connect and seems to vibrate and beeps repeatedly

I have also tried to connect other devices (another Chuwi Gempad, an external HDD) and cannot get any data connection to those either. I have tried all devices with several different USB C cables, and also attempted to cut-back one of the plastic sleeves on one, as I see this was a potential solution for another similar Chuwi tablet issue.

Is the USB C port simply for charging? Because if so, then this tablet is not fit for my purpose and I will be returning it

Please advise - thanks

Great support response. Guess I’ll be filing that product return after all

Hipad X 6gb brand new here.

Can’t connect to PC (nor Mac) , reinstalled lots of Android ADB drivers, nothing. I have tons of MP3 to transfers I need for work.

Please help!

Hi @DJIMark , please read my answer here
Does this help?