Hello all,
I’m a newbie, just received my Ubook Pro N4100 a week ago.

As in the title, I cannot boot from any USB key… As first thing, I saved my system with Easeus Todo Backup and now I’m trying from the boot disk of Easeus. Just to be sure that in the case I’m able to use my backup in order to restore the original system. Anyway, these my attempts:

  1. changed in the bios the boot mode UEFI / LEGACY ==> nothing
  2. rearranging the order of boot devices, USB before than HDD ==> nothing
  3. prepared with RUFUS my keys ( GPT of course ) ==> nothing
  4. tried 4 different USB keys in both USB3 ports of the tablet ==> nothing
  5. tried Easeus Disk ( Win PE mode ) and Windows 10 ==> nothing
  6. tried to keep pressed F7 of the keyboard after reboot / turning on ==> nothing
  7. tried to press F7 many times after reboot / turning on ==> nothing
  8. tried to boot directly into USB from Bios boot consolle mode ==> nothing

Only original Win 10 seems to be able to start, I don’t understand. It’s not the first Win tablet for me but I’ve tried all ways I know… Help please…

Just noticed that I’ve written the message in the wrong section of the forum. Please mods, move my topic to Ubook Pro’ section… Thx

I don’t have the LapBook pro to try, but you should try, if F7 doesn’t work, with Fn and F7.
If it doesn’t work either, try F12 or FN and F12

You should not touch anything on the Bios, so you should put it exactly the same as it came from the factory.

Yep thx, infact I’ve brought back bios settings to original situation. I’ll give a try to FN + F7 or FN + F12 and I’ll tell you something. Thx again !

Thank you very much, it could be useful :ok_hand:

Ok, a little update…

  1. If I turn on or reboot the tablet, immediately pressing FN + F7 works. I’m able ti see the blue boot menu with my USB keys

  2. Unfortunately then, if I press ENTER on a USB key, nothing happens. Simply it remains on the blue boot menu. I’ve tried all my USB keys prepared for UEFI GPT


What if, instead of using Rufus, you configure a bootable pen with Windows 10 and with the media management tool?

I can try THX but I’m not so sure that there aren’t settings to be modified in the bios 'cause tablet recognizes the bootable USB keys but then it seems to not allow them to boot…

Did you rename during Format ( in NTFS ) the USB as WINPE ??

And I’ve tried to format both in NTFS or FAT32 too. Renaming the USB label into WINDOWS or WINPE. But same behavior, I see the USB device in the Bios Boot Menu but pressing ENTER nothing happens.

Ok, one only USB key is working fine now. I’ve used:

  • Easeus Boot ISO - WinPE Version
  • GPT Disk
  • UEFI Mode
  • NTFS Format
  • Cluster Size 4096 Bytes
  • RUFUS ==> LATEST RELEASE ( 3.10 )

With my previous version of RUFUS, USB keys didn’t boot. With latest one, Easeus boots fine :smiling_face_with_three_hearts: