Tablet cant recognize chuwi pen

What should I do in order for my tablet to recognize my recently acquired chuwi pen

1 Like

First make sure you’re using the correct pen for the correct device. Ubook Pro and newer Hi10X only support H6 or H7-pen, older Hi10X only supports H3-pen. Second, make sure the pen is properly charged (H6/7) or doesn’t have a depleted AAAA-battery (H3). Third, it might be driver related. (I’ll try and find the forum post about this)

So far every time I’ve started using a new Chuwi pen, didn’t matter if it was the H6 on Ubook Pro or H3 on my wife’s Hi10X, it worked out-of-the-box. The only time it didn’t, the battery was depleted.

I’m completely sure i am using rhe correct pen for my tablet. My daughter has the same tablet and same pen model and both pens ( mine and hers) work well in her tablet but not in mine. The only difference between my daughter tablet and mine is drivers, specifically one pen driver. I tried to correct that but I fpund it quite difficult, I think I’ve install the wrong driver because pen continued to be unuseful and my touch screen got screwed so I’ve restored windows from scratch. Now my touch screen is OK but my pen isn’t working.

I´m sure I´m using the correct pen and of course is correctly charged (this is the first thing I do with every battery support device I bought), it is fully charged. As I told you before, unfortunately, and I say unfortunately because is quite difficult for me to solve it, the problem is drivers. I took a picture of my daughter´s HIDs (same tablet as mine) and there´s a difference in drivers between hers and mine.