Tablet "charging" but not holding the Charge

My Hi10x isn’t charging but says it is, any ideas?

The tablet was working fine on battery however it will not charge now - it says its charging and the % goes up, but as soon as the power is disconnected it shuts down, when restarting it plugged in, its back to 0% and charging up. The low battery also pops up when booting.

It is not the power drivers, as I have updated them.

I am using the supplied 12V 2A charger that was supplied and again for all appearance its charging and working fine (red charging light works plugged in) but just not taking or holding the charge - again it was working on battery before being fully discharged.

Any Ideas?

Maybe you need to reconnect the battery or it could be an EC firmware bug.

1 Like

Thank you Biosham,
Unfortunately with the Hi10 X its non-removable, Just praying its something software(which it won’t be) as I’ve had issues with the drivers before and reinstalled them all.

Also purchased a 12v 3a charger in the hope that helps rather than shipping to China and back.

it’s removable, but you need a little experience to open the back cover without damaging tablet.

Thanks for the advice, and I would be tempted to look at that however it’s still under warranty and if its something worse I’d have no clue on how to fix. Love the avatar btw!

Ok Story time,

Serial Number: Q128GH62060****

In an attempt to update the pen drivers to make the buttons configurable I installed the latest hi6 drivers from the official website posted. HID driver update for HiPen H6

This was the wrong thing to do and it was only in the user comments farther down where several users have reported the same error as there is no warning on the main post or version check within the exe.

This has made the touch screen and pen unresponsive and ghosting. https://www.youtube.com/watch?v=X6caXf-rRuk

In my opinion the hid_i2c_update-20180419.exe has reconfigured the Hi10 x into a Ubook Pro and that may explain the touch screen issues.

In my attempt to fix these issue and under the instruction of Chuwi Support I have since reinstalled the supplied drivers several times and at one point have gotten it working. It is not working at all now. However I have also found a second issue that the battery is not charging. It had been running on the battery out the box but unable to recharge. I have included a video. https://youtu.be/aeHf9mFpFEo

It shows as charging but is not. This could be a DOA problem in the charging circuitry.
I have purchased a new 12V 3A charger and it is still acting the same.

I have been supplied with this link http://www.mediafire.com/folder/vh5zqntzyahwf/HI10%20X and reinstalled both versions of the bios, both versions of Windows and reinstalled the drivers from both the mediafire link and the drivers found at [Double Driver] Hi10 X Fresh Install Drivers

I have also tried to reinstall the I2C HID Driver from when I had the touchscreen working but when I noticed the battery issue I proceeded to backup the drivers and reinstall the OS, Bios and Drivers. This has not worked.

It says code 10 driver error, ACPI DSM error when I force the I2C driver (as the goodixtouch driver has never worked for me) and I believe this to be the issue potentially for the battery too some sort of ACPI DSM issue.

During the last OS install I tried the developer tests. And this was the battery test and the touchscreen test was a manual test and thus failed.

I have also had issues with reinstalling some bios versions and had issues.

At this point I feel like I have tried everything and while the device boots fine any more I do will make it worse.

Is there an easy way to fix this?

Thanks for reading - I have emailed this to support but you guys seem to know what your doing and they seem keen on me sending it back for repair at a cost.

Update for people searching,

I have managed to get the Touch Screen working by changing Bios settings - it had somehow been disabled

Chipset> South Cluster Configuration> Miscellaneous Configuration> Then I enabled Touch Pad Device and selected the GoodixGt7385 Device.

Again I followed someone else’s advice from a random forum post and it worked, I only hope the battery situation can be similar issue??