Vi8 only backlight no logo no bios


I have a Vi8 Dual OS tablet which went to bricked.
Its a Android+Windows tablet with 32 GB memory.
Due to lower storage and less use of Android OS,I deleted the android partition and used only for windows 8.1.
Tablet is all fine but having some issues with battery
(Longer charging time,Short battery life).
Last week I used the tablet till 1% battery and it went off.I charge for long time but it doesn’t open.
I try to enter bios menu with otg keyboard but it’s not working.When I press the power button only backlight lights up,but there is no Chuwi logo.
I tried power buttons 30s etc but still not working.
Sometimes,green notification lights appear but there’s nothing on screen.
I also connect via hdmi to tv but nothing appear on screen.
Are there anyway I can fix my tablet ?
Do I need to install firmware or something?
Please help me to fix this.

Thanks a lot

Hello,please contact with’ll help you figure out what went wrong.

I live in Myanmar.
There’s no service centre here.

The tablet should never be used until the battery is completely discharged. When the device starts telling you to connect the charger it is time to charge the battery.
The reason it does not turn on is, almost certainly, that it does not have enough voltage to start.
To solve this, you must put the charger for many hours (maybe days) until the device turns on normally since the battery has a locking system to avoid discharging completely and it has been activated.

Thanks a lot :smiley:
I will try this