USB was working, now not recognizing network adapter

I have a USB 3 RJ45 adapter that also has 3 USB extensions in it. For months it worked fine, but recently, whilst it still works for things plugged into the 3 USB extensions, the CHUWI no longer recognizes the RJ45 network connection. The adapter works fine when plugged into another laptop. I’ve tried uninstalling and re-installing the drivers. Also when I plug in a similar one into the USB-C port it works fine (though due to the old CHUWI USB-C issue the battery drains, so this is not a permenant solution.

In summary it seems the laptop is not recoginzing the RJ45. HELP please.

You didn’t say what model of Chuwi you were using. Did Windows do an update right before it stopped working? Could be a problem (I’ve had that one), just undo the last update. Can you use WiFi instead?

Thanks for your info CrumblePie. Its a CHUWI UBook Pro 12.3 Inch. I cant recall if windows did an update, they seem to come automatically overnight. Yes Wifi works just fine. Bizarrely I was asked if I wanted to install Java - which I did and after that, the adapter started working just fine. I cant believe the driver uses Java, it must just be some form of Windows reset that fixed it. I’m a happy bunny now, only fearing the next time this just happes without explanation!

Oh yes, Windows does updates as and when it feels like it, usually without warning and it’s stopped my computers working altogether sometimes. I’ve disabled updates on my HI10 altogether, and make regular backups with Acronis on my main PC. It’s killed both before now and it’s damned annoying. Bloody Microsoft. At least yours is working again so all is well. :grinning: