WIN10 21H1 update does not install

I have just bought a Corebook X14 with i5-8259U cpu and tried to update Windows to the latest version but only get 20H2.
I have looked at the security functions. The TPM module is not listed in Windows but is present and active in the BIOS.
What do I need to do to get the latest Windows 21H1 updates?
Thanks in advance.

Hello and welcome to the forum.
I just installed 21H2 in my CoreBook X purchased last June. Updates are normally offered by Windows Update as they are made available. So, I suggest patiently waiting for Windows Update to offer the updates for your CoreBook X. I am attaching two screenshots of today’s Windows Update for my PC.


Hello,
thanks for the reply.
Last night I did a search on the Microsoft website and found out that it is possible to force an update if the computer is compatible via the software-download section.
The utility first checks that the computer is compatible and then telecharges an .exe and does the update.
The computer now has Windows 10 21H2 installed.
BUT in the parameters security section the computer still does not show the TPM status - it is completely blank.
The utility did say that the TPM 2.0 is active and the computer received the notification that it is comptaible with Win 11 and that I can update to it if I want which is again proof that the TPM version 2.0 is present and activated.
So my problem is resolved at 99% - the other 1% being the blank TPM status!

Hello. In that case I would try restoring Windows 10.

You may also want to read this article.

Hello,
yes I had thought about resetting the TPM but hesitated.
Now I know that I can also re-install Windows without losing Office etc I will do it.
I will post the result tomorrow.

I’ve cleared the keys, reset the TPM as per the article. The TPM works, there are no erreurs but there are still no details displayed.
The one thing left to do is to get a new updated BIOS firmware if it exists.

Does anyone know what is the latest BIOS release so that I can check against what I have?

Incidently also today Windows update found the feature update to Windows 21H2 released today so latest updates happen automatically.

The BIOS on my CoreBook X:
Version 2.20.1275. Copyright (C) 2021 American Megatrends, Inc.
BIOS Vendor American Megatrends
Core Version 5.13
Compliancy UEFI 2.7; PI 1.6
Project Version CFL CM131_U43E_V1.0.5
Build Date and Time 05/08/2021 19:10:33
EC Version 902.001.717
EC Build Date and Time 05/10/2021 11:29:38
Access Level Administrator

When everything works, I stick to the rule “If it works, don’t fix it”.

The BIOS on my Corebook X is
Project Version CFL CM131_U43E_V1.0.8.
EC Build date 05/21/2021.

So its a later version than yours.

I did a complete Windows 10 re-installation from zero from the cloud not my machine and got all the latest updates. The PC appears to run faster (good news) BUT there is still no information in the TPM security processor section in Windows security.

This computer is a Xmas present for my grnd-daughter and I have bought another one for myself which I received this afternoon. It has the same BIOS release as the first one BUT there is the tpm data in Windows security section!!!
I am doing the set-up and updates and will check at each stage to make sure that I don’t lose the data display and the start looking for what is different.

It’s great to have two identical machines to compare. Please share your findings here, so we can all learn. You can add the title TPM Expert on your business cards! :slight_smile:

Hi,
I’ve not replied immediately because I have spent the last few days trying to update the 1st Corebook that I bought to Win 11.
The 2nd one was easy to update - I had no problem.
That one showed the TPM information in Win 10.
The other one does not update to Win 11.

At first I tried to do all the latest updates in Windows 10 but it would only update to 20H2 not 21H2.

When I tried updating to Windows 11 it updated to Windows 10 21H2 !!!

I have tried several times to update to Win 11 after changing some settings for memory control but with no success.

I do not get any error messages and the troubleshooters do not find anything wrong.

I have found 2 differences between the PC’s.

The one that does not update does not show the TPM information in the settings.

The PC Health check gives the data and says that it is present and enabled.

When I look in the BIOS the TPM is present and activated.

The PC that I have updated to Win 11 does show the TPM data in settings.

The other difference is in the BIOS TCG Storage configuration.

The PC that updates has “Kingston OM8PC3512F-A02”

The PC that doesn’t update has” Kingston RBUSNS8154P3512GJ”

Both PC’s have the same BIOS version CFL_CM131_U43E_V1.0.8.

They both have the same EC version V1.04

They both have the same build date and time !!!

I have sent an email to Chuwi service with the above info and asked for the BIOS which has the working Kingston configuration.If anyone has the BIOS with the configuration “Kingston OM8PC3512F-A02", I would be grateful if they could send it to me and tell me how to flash it.

Or is it possible to copy my good one and use that to flash my BIOS ???
I cannot see any other difference in the BIOS on the 2 machines.

I

Since my original problem has solved itself by trying to install Win 11, the title is no longer valid !!!
I will start a new subject with my problem to install Win 11.