Windows Update cannot be enabled

Hi there,

Recently I have purchased a Chuwi Hi10 XR and was setting up no issue.

Then I turned off the windows update.

Lately, I wanted to install some programs from MS Store, however, it needs the windows update to be ENABLED.

I tried to enable the WINDOWS update, but it wont not turn on (Manual, or Automatic). Although it can be STARTED, but Windows Update just wont not run.

I checked the services.msc and the status on WINDOWS UPDATE remains DISABLED.

As advise on how to resolve this issue without reinstalling Windows?


WindowsUpdate is started as “manual” as default, that is, it starts to run by triggers made by the other software.
If you just disabled WindowsUpdate from services.msc, setting it “manual” is enough to work correctly. In fact I installed CandyCrush by setting it “manual” and after installation disabled it.

How did you disable WindowsUpdate? with special script / regedit ?

(otherwise, starting WindowsUpdate manually might resolve the problem)

i just disabled it from the windows update after it installed bulk of the new updates.
Then it started to fail a few updates, so I select “no windows update”.
Now i cant enabled it all time and windows update keep running in a loop.

Note: sometimes i can set the to running, but still nothing happens in the Windows Update…

Hi. @BenLow

I’m not sure what causes the problem, however we can try to take some actions.

  • Run WindowsUpdate under safe-mode
  • Use system file checker (sfc.exe)

It’s the first time for me to enter safe-mode :slight_smile: , I write how to enter safe-mode below.

  1. Click Windows Button (on the lower-left corner), then Power icon
  2. Click “Restart” with Pressing SHIFT key
  3. You enter the Option screen. Select “Troubleshoot”->“Advanced options”->“Startup Settings”->“Restart”. Then, you enter Startup settings.
  4. Push F5 key to enter safe-mode, then try to run WindowsUpdate. (WindowsUpdate may sometimes take more than 30min).
  5. You can also use sfc.exe more safely than in normal mode.

Whenever you restart Windows in safe-mode, Windows returns to normal mode.

Hi EndlessBiginner,

Thanks for the steps, however, when i entered SafeMode, my windows update still shows blanks (refer to picture).

Also, this option is always DISABLED and everytime i manually change it to MANUAL triggered or AUTOMATIC,it will return to DISABLED.
And as mentioned above, when I managed to change it to MANUAL and START the service, Windows update still cannot run and when I return to Services.msc, the option return to DISABLED.

I tried reinstalling from using this “MediaCreationTool20H2.exe”, however, it failed. Tried 2 times same result…FAILED.

Any other ideas how to resolve this?

I think WindowsUpdate was interrupted on the way to completion.
Would you try to check the integrity of Windows system?

1. Open PowerShell with Administrator previledge

Right-click Windows icon on the lower-left of screen and click “Windows PowerShell (Admin)”.

Then PowerShell runs.

2. Check filesystem

In PowerShell, execute

chkdsk c: /f /x

Restart your PC. Disk check will start. I hope the success of the check.

3. Check the Integrity of Windows system

Open PowerShell (Admin) and execute

dism /Online /Cleanup-Image /CheckHealth

dism /Online /Cleanup-Image /ScanHealth

If any errors happen, execute

dism /Online /Cleanup-Image /RestoreHealth

sfc /scannow

If done successfully, restart PC.
If any errors happen here, I think reinstall of Windows is needed.

4. Clear temporary files

Open PowerShell (Admin) and execute

cleanmgr /d C: /VERYLOWDISK

Then, restart PC.
NOTE: WindowsUpdate sometime uses a few tens gigabyte storage to work. Preserve enough free disk space.

After all above, try to enable WindowsUpdate.
(I recommend that “fast startup” mode is disabled. See Standby issue hi10 x - #33 by EndlessBiginner)


I have the factory preset Windows10 install image for USB drive from CHUWI.
The image is for Hi10X later version (S/N Q128GH6…).
If you need, I send you URLs.

Will it work with Hi10 XR?

S/N Q128G20104972 compatible with this?

Oh…it’s dangerous to apply my install image to Hi10XR

XR is equipped with N4120, X is N4100.
So it’s possible that BIOS causes errors (the install image has BIOS in it).
Please contact CHUWI support.

This is not Chuwi support??? :thinking:


This forum was probably started by CHUWI, but the support of CHUWI has already stopped before 4 months at least, except annoucements for new CHUWI products.

I saw a number of replies to ask @Management to solve forum/PC problems and no answer from @Management :cry: .

Of course, I’m perfectly a volunteer user of this forum. If you click my icon, you can see I am just a member of the forum… Most of us are just members. As far as I know, only 3 users have administration privilege of the forum.

OIC, okok. BTW, how to enable “check filesystem”?
I managed to go to PowerShell. What command to start the filesystem check?

Click arrows in my reply, then details are shown :smile:

:weary: chkdsk and DISM command cannot be executed…have errors…

sfc command can run, and found no issue.

Do you remember what kind of error has occurred when chkdsk?
Anyway, it seems to be good to back up all data.

If errors occur from bad blocks in SSD, full-format (not quick format) may make SSD in proper status. That is, reinstall Windows10…

would u have any windows 10 image for hi10 xr?

cos windows update is not “MUST HAVE” but some of the apps i wanted to install from windows store requires Windows Update to be enabled and running, and to get updates on security.

Other than that, not that MUST HAVE for me… :grinning:


I have another issue here…ever since i run the commands above, now my XR is having a hard time to boot up.

When ever it does on sleep or shutdown, i have to press the “start” button a few times (with no effect) before it gets powered up and boot up windows. Battery is fully charged.

I do not know what happen.