Accessing BIOS

Hi Chuwi,

Can you tell me how I can access the BIOS (on my UBook) at startup?

Regards,
-Wakdidin-

immediately after pressing the power button, press Esc several times

Got it. Thanks “manonegra222”.

Does anyone knows how to tweak the BIOS so that the UBook boots from a USB device 1st before accessing the SSD?

Thanks I advance.
-Wakdidin-

Is there a reset / Cmos reset function on this Bios?
keyboard shortcut or something…?

Can we edit Settings in Bios and in the worst case we can Back with it?

Turning on with the pendrive on, you must enter the bios by pressing Esc several times until the bios screen comes out. Once there, go to the Boot tab and select the boot order preference line. Press enter on that line and select the Pendrive there.
Once set, save the changes and exit.

1 Like

Hi my Chuwi UBook Pro simply gone dead with total Black screen of Death. Doesn’t boot. Only the blue led can be seen when I press the power button. Also the red led lights when the power adapter is connected (tablet is fully charged).

Looks like problem is the corrupted BIOS.
It is purchased from Amazon.com USA, Chuwi UBook Pro, N4100 model, serial no- PQ256G19110225

Could you please help me by giving me the link to the BIOS so that I can download and flash it.
Thanks

Contact service@chuwi.com .

Thanks for your reply!
I already contacted Chuwi services and they asked me the model number (N4100) and the serial number which I provided.

2 days passed still no answer from them…

Most likely this is due to coronavirus, a lot of letters have accumulated in the company. It’s better to wait for answer.
But you can try to flash “universal” bios but before this please save your original bios firmware just in case.

1 Like

Thank you so much for your reply. In the meantime I have received the BIOS file from Chuwi Services and asked an expert to do the BIOS flashing as I am not an expert. But I am sure that the OS and the hard drive (M.2 SSD are OK and loading on my other PC. I’ll update you if the BIOS will be resolved. Thanks again!

1 Like

You can blind circle around in BIOS. Pressing Esc while booting and ctrl+fn+f3, enter, then ctrl+fn+f4, enter to reboot :grinning:

Press the power and the volume + at the same time during
30 seconds.
It will force windows shut down.
Then press power button to turn on.

Can you explain me how to upgrade the bios?
The touch screen is not working and I think, if
I update the Bios, it will work.

I think a Bios update will not solve your touch problem. Your driver problem is more likely.
Anyway, in case you have already tried to reinstall the drivers, to reinstall the Bios, just turn on the tablet with the USB stick attached and pressing F7 intermittently (Fn + F7). An automatic Bios flashing process will start.
You must make sure to use the correct files since, otherwise, your tablet will be unusable

I have a Ubook Pro, but I don’t have a keyboard. In this case, is there any way to enter the bios? I do have a bluetooth keyboard, but this does not work while the PC is booting. If I use a usb keyboard, does this help?

Yes, you should be able to use a USB keyboard and pressing the ESC key right after turning it on.

A way of going into BIOS without a keyboard, in Windows 10 go into Settings…Update…Recovery and under the Advance Startup option, click the “Restart Now” button. When the computer reboots, it will come up with advance options, from there you can select “Troubleshoot”, “Advance Options”, “UEFI firmware settings” and then it will reboot again and go into BIOS.

Wow, thank you for the info.

2020年7月19日(日) 20:21 John Jaworski via CHUWI | Official Forum <chuwi@discoursemail.com>: