How to reset bios? Black screen

Hey need help urgently. My ubook pro just shows me black screen when I turn it on. Can’t access or see bios, no logo from chuwi also.

At boot up the keyboard light turns on and the blue led on the keyboard flashes one time.

What can I do???

1 Like

Please write to service@chuwi.com

Have you tried removing the keyboard and holding the power button down for about 30 seconds when turning it on?

Confirm this method, it looks like the Ubook went to the “super sleep mode” that I described on my post. Long pressing the power button should help.

Didn’t helped :confused: removed keyboard holded down the power button more then 30 secs. While I hold the power button, the chuwi goes on and off again and again.

Try to hold it a little bit shorter, for 6-7 sec as the blue lights LED gors off. Then, wait a moment and then just turn on the tablet by pressing the button until the LED lights on - the release the button.

It that doesn’t work, ask Management, maybe there is somę reset combination…

I wrote an email, how long can it take to get a reply from them?

Nope, nothing, thanks for help mate.

My last advice would be to connect external monitor to the micro hdmi port in order to check if maybe the display is broken and doesn’t turn on…

Hope CHUWI management will help because I noticed that a few other people also reported this bug - seems like it becomes common problem.

1 Like

I was successful fixing my problem. Just turned it on, waited to drain the battery to zero. As soon as it turn off by itself, I waited a few minutes more so the bios battery also discharges. After that, holded the power button down till no reaction. Plugged the charger back in, turned it on and see there, it loaded the old bios settings and so on.

IT WORKS NOW

2 Likes

Excellent! Thanks for the update.

Congrats you are damn lucky I had to our chase 10 ICs from China Because of lockdown Ivan not receive it. The power IC used DDH379 has created boot issues in other brands as well.

Yeah, I tried everything wich came in my mind. Didn’t want to brick the warranty also. So I was very lucky with it. :slight_smile:

I have a similar problem with my lapbook plus, after installing wsl2 I had this problem with the screen. still unsolved. did anyone have any luck?

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Hello. I have too my problem, did you to someone manage to solve it?

Hi. the led flashed to you… or u wait no blue led no flash. ? Thx for help

i waited until the tablet shows no reaction when i press the power button. after that waited a few minutes more, and thats it.

charger back in, pressed power button and it loaded the old bios settings by itself

1 Like

i tried all versions… correspondence with support did not help… after a long time the situation improved.