Chuwi Corebook X How to enable USB C Support

How to activate Type C
Step 1: Start your Chuwi Laptop.
Step 2: Press ESC.
Step 3: Go to the Chipset Tab.
Step 4: Choose TYPE C SUPPORT and enable it.
Step 5: Save changes and restart the Laptop.
Step 6: Enjoy your new USB-C Feature.
If you have any Questions about the CoreBook X, feel free to mention me (@) in your Thread, i will help you soon.
I am not the official CHUWI Forum Support :frowning: :wink:

3 Likes

After activating - keyboard stop work. In Windows can enter 1 symbol in 5 seconds.

Does it support USB-C charging after activating it? @CanMK

No sorry, the CoreBook doesnt support USB C Charging @Petey

Already tried. After enabling it, keyboard will become sluggish and write 1 char every 5 seconds. Unusable.

DELETED-4872.4577X35

Hey try at least 40W PD2.0 certified charger (stated on Amazon). I have bought 65W one for like 8 bucks in sale and it works like a charm. Charging and display through USB-C hub.

Hi.
AC adapter of CoreBook X is

19V/3.42A adapter,PSE, CE, UL, FCC certified

(from OVERVIEW in CoreBook X 14 inch Intel Core i5 2K 16GB+256GB | Chuwi – CHUWI STORE )

That is, USB PD seems to be required to supply 20V. USB PD charger which can supply 20V is >= 45W at least. All PD chargers >= 60W can supply 20V/3A-5A. Be careful that connectors on both USB sockets are type-C. As a result, PD 3.0 compatible >= 60W charger seems to be usable.

(CHUWI, you should note these important information on your official web page!)

I don’t recommend using other chargers.

I’m in the same situation. How to solve the problem? Even disabling type c support, my keyboard still doesn’t work.

No modifications should be made to the BIOS, it may even lock your computer.
The coreBook X does support C port charging and you will need a charger with at least 65Wats of power and compatible with Power Delivery.
I have done the tests myself, both with a C charger and with a Power Bank and it works.

I beg users not to give miraculous answers without trying them that can cause problems rather than solve, complicate the correct operation of the devices.
Sometimes ignorance is bold.

yes, now is clear. By the way, I’ve found the solution. You have to force the shutdown by pressing the on/off button, then, enter in BIOS configuration and select “Save Changes & Reset” option. After that, the pc works fine.

thanks for sharing, it will help others

1 Like

HA SIKTIR DU HURENSOHN

Does anyone know if it is possible to recover the keyboard responsiveness after doing this? Any solutions? I wish I knew I couldnt mess with this setting before I did it