ChuWi Hi10 Model CWI515 - docking a Keyboard

Hallo there

I bought years ago a Tablet with dual boot, a Hi10 Plus, Model CW1527, with Docking Keyboard (from Hongkong, about 40.- eur) which still runs.
The MicroSD-slot doesnt work since long (does not recognize any MicroSD anymore) and later the Keyboard Docking Cover was not working neither, so I connected a HF wireless (no BT) Keyboard to MicroUSB, which works.
I rooted it successfully along this manual: TWRP 3.0.2-0
Three years ago (17.11.2020) I broke a bit the display, so the Touchscreen stopped working, which made it worse.
Still for some use-cases it is a good device (only Windows, Android I rarely use anymore, not enough ROM for Android and without MicroSD nearly unusable).

Now I found a ChuWi Hi10 Model CWi515 (with 2 x USB-A slots instead of C and MicroUSB).
I tried to connect my Keyboard Docking Cover from my old CW1527, but the two bumps doesnt fit to the tablet, they are too narrow together. I cut then some milimeter of the bumps, so now it fits, the contacts connect exactly I think, but the keyboard is still not working. Something is happening in Windows though, when I connect, the Taskbar is changing, but I cannot use the keyboard. OK, I dont know if the keyboard itself is broken or the CW1527. I thought it would be the contacts of the CW1527 but I can be wrong.

Is there maybe some software driver I would need?
Or where could I buy a original fitting docking keyboard for the CWi515?

Thanks for help

Could you Please give us your exact model plus Serial Number?of both tablet and keyboard.To check the drivers and see if that would solve it

1 Like

OK, my old one was not Model CW1527 but CWI527 (not 1 but capital i).
There is written 4G+64G Hi10 LQ64G42170901615 on it, so I guess this is the serial number.

The one I just bought is now CWI515 (seems to be an older model then). It has the serial (?) number on it:
Hi10 Q64G42160700268

The keyboard with docking has not any number written on it. It fits to the CWI527 though and worked before (I think the CWI527 docking is the problem, not the keyboard, but not sure).

I asked my colleagues they provided me with this drivers. Install them and see. But as the model is discontinued and we dont have more keyboards. They are aware of the problem of the connectors.Other users reported that years ago.

@manonegra222 cogelos

1 Like

Thanks a lot already :smile: Will try it!

By the way, do you know if it is possible to repair the Android partition?
The new (old) CWI515 has no more Android on it, the pre-owner destroyed it by formatting the 12 GB partition (?) in Windows, I guess to get more storage space. Anyway, if I boot into Android, there is a message that it cannot start, I get some Recovery screen, where I cannot recover Android.

Is there a way, to restore the ROM on the partition?
I have the other ChuWi, that CWI527 device, here I can still use Android, from that I could copy the ROM maybe? But with which tool and how? Is it possible to boot the device with an usb-stick where I put Linux on it e.g.?
Possible? Could you ask your colleagues about that?

PS.: I guess (I read) to access the BIOS I need a wireless (not BT) keyboard (which I have) and press F7 while starting.

hi10 Q64G42160700268 OS link:

LQ64G42170901615 OS link:

Flash tools and tutorials

If you have any doubt @manonegra can help you to know how to install. The last two files are tutorials. But just in case.

1 Like

Yes, it is possible to restore the Android partition and use it, but keep in mind that it will be Android 5.1 and you will not be able to install a more modern version. In addition, to do this you would have to install Windows again since it is taking up all the storage space. Assess if this is what you want and write again if you want help getting it.

Here a tutorial in spanish (use google translator) and don’t touch the bios: Tutorial Restaurar Chuwi Hi10 Pro

Thank! No, the Android partition is not unified with the Windows partition, it is a separate partition in the Disk Utility from Windows. I guess the previous owner formatted that partition for Windows to get more storage space.
So I think that I could try to restore the ROM to that partition with the tool.
I will try soon. Yes I know that it is only Android 5.1 but this is better than no Android. Most apps still run on 5.1

if you do it and it is succesdull please come back here to tell us, so it will help next customers:)

OK, after some try and error I ended with a not anymore booting Windows (I got a BOD).

So I thought I could at least install just and only Ubuntu on my ChuWi Hi10 but after the install (through a ubuntu pen drive) I still get the Boot Loader with Android! Without Windows Icon now (because I deleted all partitions when installing), there is only the Android Icon and the device wont start like this.
I can select Ubuntu now with F7 on start, and I managed to start it via Ubuntu’s second boot choice (other ubuntu start options or such), but this is a bit unhandy :frowning:

How can I get rid of this Android bootloader? Is it fixed in the BIOS? I tried to switch there to Boot > Ubuntu, but still I get this Android Bootloader, grub (ubuntu) Bootloader is not visible, only after booting via F7 into ubuntu. The settings in the BIOS wont save, when I try to set as primary boot my new Ubuntu.

And there is missing the driver for the touchscreen in Ubuntu, can I find this anywhere? Could this fix work?

Can I go back at least to restore Android 5.1 and Windows 10 Home anymore now, since I deleted all partitions?
Is there any restore program to get the factory state? With the Intel Phone Flash Tool maybe?

maybe @manonegra222 can help you better, you have the links to the OS

Yes, it is possible to restore both systems to factory settings, first Android and then Windows with the Forum room files. For Android you must use the Phone Flash tool and for Windows simply boot with a pendrive where the self-installable room has been unzipped.

Thank @manonegra222 Rafael!
Tell me please another thing: can I replace the default Android-Windows Boot selection screen?
I have installed Ubuntu 22.04 now, beside the Touch all is working and the touch driver could maybe installed, maybe, following this how-to..
But at the moment, I can only boot to Ubuntu with F7 and Boot menu. Not with the default Android-windows-selection (where Windows is missing now, after I cleaned all partitions with ubuntu).
In the BIOS, any setting related to the boot is not editable, it does not save if I change there anything. I guess this Boot-Selection is just hardcoded in the bios :cry:

Is there maybe a way to edit this screen anyway? To delete it completely and get directyl my Ubuntu grub bootloader?

Thanks advancingly :smile:

@leledumbo maybe also can help about linux

If it’s x86, in theory you should be able to replace it with practically any boot manager in existence. rEFInd is my recommendation since not only it will scan every bootable in all drives it can find, it can also boot Linux kernel directly (albeit without any kernel parameters by default),

I don’t know what this Android-Windows boot menu you’re talking about since I don’t have the device, it’s probably hardcoded for just those two.

It is possible to deactivate the dual menu, but from Windows, using an Excel file whose link I put below. Just run it and answer no to the question “Do you want to move to Android?” then answer the following question with disable.!AqpKvT8-VB_8t150c07rF_uqovm9

@manonegra222 Rafael
Oh, thank you very much! But Windows is gone already, I have only Ubuntu now. Can I maybe edit it from there? I dont even know where that code of that Dual Menu resides, it is in the BIOS?
What does this program do, this SwitchNow.exe? I guess there is nothing comparable for Linux?

@leledumbo Mario Ray Mahardhika
That Dual Menu which I mean is the one, where I could choose between Android and Windows, for 10 seconds, if I dont input something. The choice can be switched with the Volume Buttons and it is done with the Power Button. For both Android and Windows, there are icons. But now, having neither Android, nor Windows, I see only the Android icon and it does not boot into Ubuntu at all, I always need F7.