Chuwi Lapbook Pro 8GB/256GB keeps booting to BIOS. Cannot detect LINUX OS

I have installed Debian LINUX and updated grub to install to /dev/sda (NETAC SSD)

After completing installation and reboot, the Lapbook Pro keeps going back into BIOS.
In ‘Save & Exit’ → Boot Override section, I cannot see my OS - only ‘Windows - Push Button Reset’ is listed, but that does not really exist.

In 'Security" → “P1:Netac SSD 256GB” - I can see ‘Security Frozen: Yes’ and ‘HDD Master Pwd Status: INSTALLED’

I can confirm I did not set any password or anything like that.
How do I fix this? What are the correct bios settings to use? Do i need to reflash bios E.G140J.D8.E1.016 ?

Disable UEFI boot and allow legacy boot

1 Like

Yes this definitely sounds like a secure-boot issue. As Orion has said use legacy boot. Usually when major Linux distros install, one of the questions they ask during install is if you want to disable secure boot.

‘Attempt Secure Boot’ is [Disabled] Not Active
Secure Boot Mode is [Customized]

It still will not boot GRUB from MBR /dev/sda.

What do I need to do to make it work for:
‘Install Factory Default keys’
‘Reset to Setup Mode’
‘Key Management’

Once you boot into BIOS, look at the Boot Order. You will see a Windows bootloader in there; the GRUB one may be lower numerically in order, so when the system tries to boot Windows (That bootloader will remain) it looks for Windows on the target disk, does not find it and defaults to BIOS. If that is not the case, did you install Linux with Secure Boot disabled? If not the Linux installer may have installed the OS, but when it tried to write a GRUB entry in the MBR it could not as secure was still active. Do you recall if the installer asked you if you wanted to disable Secure Boot?

I don’t know what Chuwi does with the bios E.G140J.D8.E1.016 - there is seems to be no real way to disable secure boot, even when disable is selected. I got LINUX to boot by creating EFI partition.

As long as you have it booting that is great! The only thing that comes to mind is maybe they are locking the BIOS like that to discourage rootkit attacks?