Chuwi LapBook Pro Charger burned in the first day of usage

Dear sirs,

I’ve bought my CHUWI LabBook Pro at banggoog web site.
And until now they didn’t provide a solution.
The CHUWI LabBook Pro started to worked right away and without problems!
The problem occurred in the same day I receive it, and a while after I had connected the charger to the notebook. Suddenly, I heard a noise, the room light went off and the charger started to smell burnt.
I remove it from the notebook and restore my house power as the power panel went off.
The charger light do not turn on again when reconnected to power and It seams to have a loose piece inside.
How can I have this problem solved.
Is the usb-c port in the laptop compatible with usb-c chargers that provide multiple power configurations negotiated with the notebook. For example o with the following specifications: (input): 100-240V (output): 5V-2A, 9V-2A, 12V-2A, 14.5V-2A, 15V-3A, 20V-2.25A (65W)

I would like to solve this issue as soon as possible.

Best regards,
Rui CC