USB-C charging port is not working

I am using my UBook Pro a lot on the go and therefore wanted to use the USB-C charging port to power it while not at home or in my office but I found that the charging port is get getting enough power to charge the tablet when it is running and sometimes also not when it is off.
Is there any issue with the USB-C charing port and if yes, how can I fix it to allow charging via the port?

I can use the USB-C for charging with no issues. Make sure you are using a 45W PD 2.0 type charger with the appropriate rated cables. I can charge via USB-C either powered on or powered off.

1 Like

Thanks for the advice, I was always able to charge my Hi10Pro with a normal USB charger and did not need a 45W PD 2.0 device to do so, I guess that has changed now and I need to invest in a better USB charger now to continue using the USB charging option.

Chuwi Laptops require 12V 2A power input. I have PZOZ 24W PD charger and Xiaomi 45W PD charger. Both of them works fine. I also have Xiaomi Power Bank. Expensive but excellent.

I have the Lapbook Pro 8GB version and have tried different PD chargers and unfortunately NONE of them worked. I have wasted a lot of time and money on finding a backup charger but cant seem to find one that works. I have read somewhere here in the forum that Chuwi Lapbook Pro doest NOT support PD chargers. Not even regular 12v/2a chargers work. Only the one that came with the laptop works. I wanted to buy the PZOZ charger you mentioned but I am afraid that it’s going to be yet another waste.

mines are doing the same. though i havent tried charging them over usb-c, but if i connect my usb-c nvme drive the tablet will stop charging and will start draining the battery, only happens if i connect the drive to the usb-c, if its connected to a normal usb 3.0 the tablet will keep charging.\

at first i thought the drive was draining too much power, but it’s not the case, given in an usb 3.0 works properly and charges properly.

my guess is when the the tablet detects an usb-c device, it disconects the charging connector, even tho windwows says its still charging :confused:

i havent yet tested other usb-c outputs but as soon as i get a dongle and a charger i will reply back again

I have connected both my Android tablet and a SSD drive directly to my USB-C port and don’t have any issue with the UBook Pro stop charging. It remains at 100% and doesn’t lose any battery.

Do you have a USB hub hooked up as well to the USB-C port? I connected my devices directly.

nope, directly. i have small usb-c nvme case. i have to find more stuff to try and connect.

I hope that Chuwi will also do the tests that we have already performed and check why their devices have the USB-C battery drainage issue.
This needs to be fixed asap.

Good day. I really like using my UBook and have been doing much different task. However, today I was trying to use my Type C port and found it not working. I went into the BIOS and saw that my USB Type C port is disabled and I have no way to enable it. Please help. Thank you.

Hi, I didn’t know my Ubook Pro (12.3’) could be charged with through its USB-C. I’m wondering it this charger is compatible with this tablet?

Yes, that Baseus charger should work fine.

1 Like

I have the same issue. The type-C port can only charge my phone, but can’t connect any other device ,even the PD charger .

Have you tried restoring the BIOS back to the default settings?

конкретно это зарядное устройство заряжает UBOOK PRO через USB-C. передача данных отключена в BIOS