CoreBook x 14" Intel i5-8259U

I have purchased a CoreBook x 14" Intel i5-8259U, I have BIOS version 2.20.1271, but I need 2.20.1275 or newer as UBUNTU doesn’t recognize the battery. Battery is recognize on “Chuwi AeroBook Pro” but not the CoreBook X 14" how can this be? On the box it has Linux as an option, so why not update the Bios and supply it? @ChuwiSpainSupport

Hi, Clay. I wonder if you have tried this:

I have seen it but how is this going to help me?

As i said in another post you wrote, try contacting the person you said he got the Bios Version .75 and it solved the issue. Because i do not know where did you read the info. If he tells you the Serial Number of his computer and the Bios Serial Number like Jxx-23C- xxxx-xxxx he got from us ,(not just Version 2.20.1275) i will be able to locate the same file he was given, and send to you. or maybe if he wrote us, by his email i may be able to locate it also.

Maybe by entering the serial number of your laptop you could see if it has what you need.