Corebook X fan noise

hi guys i bought a corebook x a few days ago and im satisfied with it ,there is just one huge problem the fan it’s to noisy ,it goes 100% or so all the time also with temp around 50 grades ,when using google chrome,word,open mail exc. ,do you have any fix for that? the only thing that i tried is limit the cpu power to 80% and helped a lot,now the fan noise is susteinable but obviusly i have 20 % less cpu power.So if you have any suggestion please tell me .

@Management do you have some firmware update or bios setting to fix this?

I’ve found a way, to turn off your Fans or make it runs slower.
BIOS > Advanced > Thermal Configuration

well if you turn it off the pc is gonna melt hahaha, im not that advanced ,how do you access bios ?

1 Like

Hey @kekw18,
If you turn on your CHUWI CoreBook X, just press ESC directly before the CHUWI Logo comes up.
Best Regards

thanks man have a nice day!

1 Like

@CanMK hi sorry if I ask you again but thoose ares the regular settings ,what did you put i dont want to do trial and error :sweat_smile: ,thanks in advace for the help


Do you think that this General Laptop setting will do?
*0-40 degrees: 20% fan speed
*40-55 degrees: 20% – 35% fan speed
*55-70 degrees: 35% – 60% fan speed
*70-100 degrees: 60% – 85% fan speed

This are better configs bro.

Did this do anything? Mine completely ignores it. No matter what I put there.

@Davoid same for me im still using the power limit for cpu ,that works (you can change it from the battery setting)

@CanMK I have tried multiple settings in the bios, but they all seem to have no effect?

The only thing that seems to work is disabling the “Turbo Boost Short Power Max” via the Intel Extreme Tuning Utility. (otherwise known as PL2)

By disabling the 35W power limit, and only using the 28W power limit, the laptop seems more quiet.

However:

  1. I can’t seem to find these settings in the BIOS?
  2. The intel utility does not apply at boot, meaning I have to re-enable it every time.
  3. Looking forward to a real solution, where the fan seems to be controlled by temperature, and not directly by the short bursts of power?

@kekw18 How were you able to limit your CPU power to 80%? Could you send some screenshot?

I also tried speedfan and MSI afterburner but both of those were unable to read/control the fan speed.

@Davoid For me it also seems that the Corebook X completely ignores the BIOS fan speed percentages based on temperatures.

@Jurian89 follow this tutorial How to Fix Noisy Laptop CPU Fan | Windows 10 Intel Core i7 i5 - YouTube ,but in the power limit put a number between 60 and 80 less is gonna slow down the computer too much, in my case im using 80 beacause the fan gets mad just after 80 %,but if you want it more silent and you don’t have to use that much the cpu you can go with 60.
Last thing ,once you do this process you don’t need to do the same thing to change the power of the pc back to 100 ,you can just tap on the battery on the right corner and put maximum ''performance" .
Hope it helps :slight_smile:

2 Likes

In my case the BIOS settings also do not have an influence on the fan noise of my Corebook X.
The power limit with 80 % is helping but this is no solution…

What is really bad in video conferences when I use the internal microphone, the fan is really loud for the listeners when I’m talking, do you also have this problem? This is a bit embarrassing for a modern laptop :frowning:

This software help a lot !
I have a CoreBook X
http://www.almico.com/sfdownload.php