eGPU Thunderbolt problem on Corebox 4th: does not work

I recently acquired a Corebox 4th to connect with an eGPU via Thunderbolt. But when I connect the Thunderbolt eGPU Case with a Radeon RX 6400 via Thunderbolt 4 cable, it shows an error in Windows notifying that the Thunderbolt service is limited, as if it was in low voltage or insufficient data transfer.

  • I have tested the graphic card and the thunderbolt cables, it’s OK.
  • I have tested the eGPU case with another graphic card, and it’s OK.
  • I tested connecting the computer directly through Thunderbolt with the 65W PD source, with the same cable, it worked without problems.
  • I accessed advanced settings on BIOS, and verified that Thunderbolt is enabled.
  • I tested my eGPU Case on another computer (Samsung Galaxy Book 2 360) with an Intel® Core™ i5-1235U Processor, the same generation as the Chuwi Corebox 4th and my graphic card was recognized on Device Manager, unlike my corebox 4th.

These tests lead to think that the problem is in my Corebox 4th.

What could be happening? Would it be a problem with the Corebox 4th thunderbolt adapter?
Or only do I need to change any settings in the bios?

I’m really enjoying my Chuwi Corebox 4th, but the main reason I bought it was to use it with an eGPU, at this point I’m quite frustrated.

I suggest for forum administrators to create a category Mini PC → Corebox 4th. Searching for content, I identified several Corebox4th users, but still without categorization. @admins

Hello
I think you should not modify the Bios without being certain. Unless you put the bios in default mode. However, if your problem is not solved, go back to the previous Bios configuration. For example, I had a problem with all the drivers with my Chuwi HeroBook pro. I asked Chuwi support, they sent me all the drivers with an installation tutorial. They were friendly and quick to help me. here is their email: service@chuwi.com. When you go to contact them, take care to explain everything to them and especially send them the serial number of the equipment and the model. Cordially

Thanks for the feedback @Ismael1 .

As soon as I received the Chuwi Corebox 4th, after performing the entire Windows 11 startup and configuration procedure, I plugged in my eGPU and the problem is the same. So I’m using the BIOS factory settings.

About the support, I’ve been keeping in touch since December 29th. I reply an update on how it works and the serial number on January 12th and so far I have not received any response.

I would like to know someone who was successful in putting an thunderbolt eGPU in the Chuwi Corebox 4th, to find out if they needed to perform any additional procedures, until the support response.

While I don’t know much about how to troubleshoot Thunderbolt problems, it sure sounds like it’s related to my docking station issue. It works very poorly and I get a similar notification. Windows doesn’t appear capable of explaining the issue in more detail.

I had to send my Core Box back to China because it was no longer working. Fortunately Paypal protected me. Never again Chuwi products. Very bad support. Very bad assistance.

1 Like