Gemibook pro N5100 8\256 No touchpad found. Linux

Initially, the touchpad worked on Windows. after installing linux (kali) touchpad not found. I re-read a lot of information and in fact there is little information about this laptop together with Linux. I tried looking in the bios for the touchpad switch, but it didn’t work. Does anyone know which switch is responsible for the touchpad in the BIOS? So that I can be sure that it is included. Because Linux does not see the touchpad, there is no such device for it.

System Information:
Operating system: Kali GNU/Linux 2022.3
KDE Plasma version: 5.25.4
Version of KDE Frameworks: 5.96.0
Qt version: 5.15.4
Kernel version: 5.18.0-kali5-amd64 (64-bit)
Graphics platform: X11
Processors: 4 × Intel® Celeron® N5100 @ 1.10GHz
Memory: 7.5 GiB RAM

─$ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ A4TECH USB Device Keyboard                id=10   [slave  pointer  (2)]
⎜   ↳ A4TECH USB Device                         id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ USB 2.0 Camera: USB Camera                id=12   [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=13   [slave  keyboard (3)]
    ↳ Intel HID events                          id=14   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=15   [slave  keyboard (3)]
    ↳ A4TECH USB Device Keyboard                id=16   [slave  keyboard (3)]

A4TECH USB Device Keyboard it`s my mouse
if you need any more information please ask me
English is not my native language. i use a translator

Use a LTS kernel - on Arch (my case):

  • linux-zen 5.19.3.zen1-1 - no touchpad
  • linux-lts 5.15.62-1 - touch-pad works

No headphones/mic/speakers so far :frowning: but the touch-pad works.

To get the speaker/headphones working you need the newer kernel (so for now it’s either touch-pad or speaker). You need to install sof-firmware, and add firmware file from ES8336 support · thesofproject/linux Wiki · GitHub In my case I had to copy sof-jsl-es8336-ssp1.tplg to /lib/firmware/intel/sof-tplg

Hey :wink:
Thanks for the tip :sunglasses:
I’m still tying to make this work, it’s still a bit tricky for me :wink: