Gemibook Pro N5100 8/256gb touchpad doesn't work under linux

I purchased a Gemibook Pro N5100 8/256GB from The touchpad works fine when booting Windows. However, the touchpad is not recognized when booting linux. The failure appears to be i2c related as the i2c_hid driver doesn’t see anything. The relevant error in the dmesg log:

i2c designware i2c_designware.0: controller timed out

Please post a fix for this issue within the Amazon return period otherwise I will have to return the laptop. Other than this problem, the machine looks pretty nice.

It seems that it is not your problem alone.

Touchpad issue is resolved by switching Kernel version to LTS (5.10.83-1) or 5.15.6-2.

Internal Audio issue still not resolved.
Tried the following Resolve Dummy Audio Output . No go.

I’m running Debian 11, kernel 5.10.140. I’ve also tried 5.18 and 6.0 from Debian backports. All behave identically, the touchpad is not recognized, i2C_designware timeout.

Further, I’ve also tried reloading the i2c-hid-acpi module and also the pinctrl-jasperlake kernel module. No change, the touchpad is not recognized. This is not an intermittent failure, the touchpad is never recognized, has never been recognized, tens of boots and module unload/reload cycles.

I did not want to boot Windows as it wastes my time. I did so just to verify that the touchpad was not dead. It works “fine” under Windows. The pointer feel is pretty bad but it works.

Also, I have a J4125 16GB/512GB GemiBook Pro that I purchased last year. The touchpad in the J4125 machine works fine under Debian 11. However, the touchpad does not have the same PNP device ID. The touchpad device ID in the N5100 machine is SYNA3602, the touchpad device ID in the J4125 machine is HTIX5288.