Touchpad doesn't work on GemiBook Pro 14

I just received the GemiBook Pro 14 today and everything is working fine besides the touchpad. I’ve installed all the Windows updates and drives and the touchpad still doesn’t work. Do i have to download a specific drive or what should I do?

Can someone please help me?

If when you first understood it, it worked correctly, it is a problem with the Windows update that could replace the touch pad driver. If you did not make a copy of the drivers at the beginning, you can request them at

Chuwi is the worst brandin performance, service, quality, customer service etc.

I have touchpad not working problem with my Gemibook 13 during the warranty period.

I have emailed several times but they do not care.

However, I have again contacted service as you suggested but I expect no response from Unreliable CHUWI.
I made a Blunder to have purchase Chuwi Laptop

did you already press Fn + Esc button to enable touchpad?

I have the same problem. Someone can post the correct driver to install? Thx