HI10 AIR boot problem

i have CHUWI HI10 AIR with windows. i bought it from BANGGOOD.
i made a mistake and installed rollbackRX i think some how it change the hdd partition.
it work fine for couple of days but after that i cant boot the windows and there is black screen after the logo of the rollbackRX and i cant uninstall this program.
i made bootable disk of windows for fresh install but windows not permit to format the disk and delete the partitions.
tryied diskpart.
AOMEI Partition Assistant bootable ISO olso not clean the partitions and even cant format the partitions.
tryied the methud that you mentioned in this page [Hi10 Air] [Tutorial] How to reinstall Windows 10 for Chuwi Hi10 Air and download the boot file but after boot it says that files are missing.
tried recover from the BIOS but also it says that are missing files.
how i can delete the partitions and format the HDD?
do i need to change something in the bios?

please help me. this is my first experience with this company and i want to buy more things in the future. prove me that i am not wrong

thank you for your answers.

Chuwi’s warranty policy does not include support for devices to which the operating system has been changed or the installed software has been modified, but this is a support forum composed of brand enthusiasts eager to help and not to feel frustrated to have acquired a Chuwi device.

Try the following:

  1. Disconnect the tablet from any internet connection -as you have no possibility to turn it on, turn off your router-
  2. Turn on the tablet and a keyboard distribution selection screen should come out, choose yours


  1. On the next screen select the “use another operating system” option and select Windows 10 (not Rollback).



  1. If you get the operating system to load, go to the lower left window and type msconfig and enter. A configuration window will open and mark the tab named boot and it will show the installed systems and allow you to remove Rollback as the default system


I have never worked with Rollback, but if you want a much less intrusive programmable disk image program, since it works within the Windows system, I advise Macrium Refect, which has a free version.

In case you do not load the operating system because with your installation attempts you have corrupted the Windows startup, comment it here and we will look for other options.

dear friend thank you for your quick answer
as i told. there is black screen when i try to boot the computer
i can’t install new system. it not let me install files to the hard drive and format.
the HDD in this tablet is GPT and it not let me change it MBR. maybe there is some kind of security?
tried to make rescue disc “Macrium Refect disc” on USB drive and follow your orders but it stack on loading.
i think the Windows startup is corrupted

thank you for your answer

Try to repair Windows startup with a pendrive with Windows 10 home multilanguage by starting and pressing F7 intermittently and in the installation menu select Advanced, Startup Repair