Hi10 Air, flashing windows stops at 21%

I am flashing windows on a hi10 air. The installation will stop at 21% every time and gives error 1392. The file or directory is corrupted and unreadable.

I then type diskpart. List disk.

Disk 0 size is 58gb but 0b free. I select the disk and type clean.

After some time I get "Diskpart has encountered an error: The semaphore timeout period has expired. See the system event log for more information. "

I tried to format just the windows volume on the disk but it hangs at 0 percent.

I ran chkdsk w: /x, it completed after 4 hours or so. But the disk still had 0b free and trying to clean the disk gave the same semaphore error.

Any ideas?


Try to disable fTPM in bios. Advanced->Platform Trust Technology->fTPM
If this does not help, then most likely you have a faulty eMMC.
To be sure it is enough to load WinPE and try to delete a large file or write a large file, if after the reboot your changes are undone, it is 100% eMMC.

Thanks for the suggestion. I turned fTPM off and it did not make a difference. I used hirens boot cd and was able to transfer a 2gb file to the drive. Kind of odd, it seemed to stop at 21% for a bit before continuing on. I rebooted and the file was still there. However, I can not open C:\users\ or C:\Progam Files (x86). It gives a corruption error. I’m thinking the eMMC is bad.