Hi8 Tablet Touch Screen functions not working after complete Windows 10 re-install

After doing a complete reinstall of the Windows 10 OS the touch screen functions do not work.

It doesn’t matter where I swipe or tap on the tablet surface - nothing works.

I used the following website reference as a guide for the reinstall:

After I installed the Operating System I installed all the Chuwi Hi8 drivers from the following location:
https://mega.nz/#!0RkDkD4Q!OGAvmx0KmJXMuoTx7Eca885iED66XjUcVp91LTnucY8

There were no issues observed during the installation of the OS or any of the Hi8 drivers. It appears everything installed successfully.

All of the Windows updates have been also installed.

I also tried the suggestion provided in a relevant article from the techtabletsdotcom website but it did not resolve the issue.

When I look at the list of drivers installed in Device Manager on my tablet I don’t see any touch driver listed under the HID section.

Moreover, when I check the system summary it says no pen or touch device is available.

I have taken a look around at some of the similar forum postings and have not found any suggestions to fix my issue.

Any suggestions on how to resolve this issue would be greatly appreciated.

Just being curious: under Device Management -> system, do you see a few Intel Serial I/O controllers? One or some of them maybe needed or need to be updated to activate the touch driver.

In the Device Manager, there are many drivers listed under the System section, but there are no Intel Serial I/O entries. There are Intel Serial I/O DMA controller entries listed under the Computer section.

It may be listed as “I2C controller (under Device Manager/System Devices)”, update this one and see what happens.

When I updated the drivers for each of the I2C Controller entries under Device Manager/System devices, they all changed to Intel® Atom™/Celeron®/Pentium® Processor Serial IO (SIO) - I2C Port 1 - OF41

Nothing else appears to have been changed or affected.

That is good. Looks like you are missing the touch driver: KMDF HID Minidriver for Touch I2C Device (SileadTouch.sys), if this or similar is not listed under HIDClass.

Today, I did a complete fresh install of the Operating System and the Hi8 drivers before doing a Windows update. There are a lot of entries listed as unknown devices. The I2C entry seems to have an issue. Also, after the installation completed and I did a restart to complete all updates, the tablet crashed. The error message was “driver power state failure”. I have no idea what caused that.Maybe an hardware issue now? Anyway, after the system completed collecting the error info, the tablet restarted.
Following is the view of the Device Manager entries right after the restart.


I have just completed another fresh install of Windows OS and Hi8 drivers and have made some progress. This time everything was installed without a crash occurence during any restart operation.

Some of the touch screen functions are working randomly, but many of the app touch functions are sporadic. For example, if I click on any area of the task bar in both portrait or landscape mode, there is no response. However, if I click on an app panel such as the Edge browser or Office, the app launches. After that, what happens is sporadic and impractical. Can’t do a search in the browser. Can’t do anything with the Office app. Very frustrating.

When looking at the Device Manager, there are no drivers listed with any errors/warnings flags. So, it appears that the touch screen driver for this device that has been installed does not have 100% functionality. My device id is: Hi8 Q32G22150800904

This may help:

Before I tried this version of the driver I ran the Windows 10 Calibrate app for pen and touch input with the driver version from the distribution I used for the complete re-install. After I did this all touch functions worked flawlessly.

After I installed this version, I ran the Calibrate app again, but it locked up. No matter how many times I pressed on the first cross-hair, it would not move forward. I had to press ctrl-alt-del, logout, login and then rollback the KMDF driver update. After a rollback, did tablet restart, ran the Calibrate app again, ran the setup, then reset. After reset, all the cross-hair points were recognized on touch and that was saved.

After this, every touch function worked flawlessly.

I finallly have my Hi8 tablet back to normal function again after weeks of trial and error!!!

In the original post (first post in this specific thread) the link I provided to use for the Chuwi Hi8 drivers is not correct for a stable installation. It should be the following source from the reference article provided in the post:
https://mega.nz/#!dA8y3JpL!t25ytdn_rGUosjZtW-ej4SoBrYQPt2QwCZFo-SwjcII

Avoid using the baytrail source version indicated in the original post(unless it is found to work only with the device id you have). I found it caused errors/warnings with numerous driver entries that were unrecoverable with my particular device which has a manufacturer release date of August 2015.

If you are installing clear windows not from chuwi you need to integrate drivers to windows image, otherwise standard Windows drivers will prevent proper driver installation.

Congratulations! All that hard work pays off.

Hi,

I’m currently having the same problem as you and I’m completely out of ideas…
My device manager looks like yours after restoring the drivers with double driver. The Intel IWD bus enumerator wasn’t restored through that process though but one such driver was already installed.
What did you differently on your third attempt to make it work ?

Any tips would be greatly appreciated !

  1. Fresh install the Windows 10 OS
  2. Use DD to install the driver versions from this source:
    https://mega.nz/file/dA8y3JpL#t25ytdn_rGUosjZtW-ej4SoBrYQPt2QwCZFo-SwjcII
  3. Calibrate the tablet screen for touch operations. Reference article here:
    https://www.windowscentral.com/how-calibrate-touch-enabled-display-windows-10
  4. Install Windows OS updates last!

If there are any glitches, crashes, etc. during any phase of the installation process, you will have to repeat until the process is clean with no hiccups from start to finish. Good luck!

Thank you, the driver archive is a keeper and calibration did help at some point but something was still missing for me.

I did make it work after a few more trials, here’s the list of what I’ve changed in my last attempt (some steps might be irrelevant but I can’t say what actually made it work in the end) :

  1. Configure BIOS to make the tablet boot to Windows (might sound silly but it was previously configured to boot to android which doesn’t prevent you to install and run W10)
  2. Boot to the W10 install media and install the Wifi driver from the archive when possible (you are allowed to pre-install a driver when the installer asks you about disk formatting)
  3. Continue the installation process, reboot and connect to Wifi when asked to
  4. At first login, restore all drivers (but the Wifi) using Double Driver then reboot. Touch screen was detected at this point but did not work properly and calibration could not solve the problem.
  5. Install the touch driver from chuwi-hi8_touch.rar included in the above link (right click on install.cmd with admin rights)
  6. Reboot and calibrate the touch screen

Hope this helps someone in the future !

Hiya, this is probably an insanely stupid question, but how did you guys check drivers etc. without use of the touch screen? I’m having the same problem after resetting windows, but I’m stuck on the first page that asks about country, time zone etc. etc. and can’t get anywhere because I can’t actually click the screen.

I had to reference a number of documents when I was trying to upgrade my tablet from a Dual OS to only Win 10 in order to gather the necessary nuggets of useful info I needed to adopt or adapt for me to apply to my own situation.

I replaced both Android 4.4 and WIn 8.1 on my Hi8 tablet with Win 10. One of the documents I used as a point of reference is:

I did not bookmark every one I found, but there are others I also used. The key info in the document is the hardware components you need to enable you to work with the tablet without the use of any touch functions. They are as follows:
OTG Cable
4 Port USB Hub
USB Flash Drive (fat32) with Win10 OS
USB Mouse & Keyboard

The perfect combination of OTG cable and USB Hub for a tablet is this component which is what I use(d):

Tablet battery should be 100% charged before starting any remedial/upgrade/install actions.
OTG cable connects from your tablet to USB hub.
USB keyboard, mouse, and Flash drive connected to USB hub.

That will enable you to work with the tablet as if it’s a small PC using conventional methods until you can get to the point where you’ve got the OS working and can then work on getting touch functionality to work.