How to install linux and modified BIOS legacy

hi.
how to modified BIOS in HeroBook (intel braswell e8000) for legacy, what options modified in BIOS for legacy for install and boot USB any system operation install, linux.

All current Linux distros support UEFI booting/installation, so there’s no need for a “legacy” BIOS mode - I don’t see such a mode in my Herobook’s UEFI and it’s not missed at all! Of more importance is Secure Boot mode, which is thankfully disabled by default, making it trivial to install Linux.

I put Manjaro MATE Linux on my Herobook (onto a SATA SSD I installed so I could dual boot with Win 10) and apart from having to install kernel 5.5 to support the touchpad and wi-fi, it was pretty straightfoward. It’s a shame that Chuwi don’t officially support Linux - when it works on their low-end laptops, it completely outshines Windows 10, IMHO.

1 Like

I hope chuwi will shake hands with manjaro :wink:

I am one of the Manjaro maintainer and I am happy that a manjaro member actually tried it and everything worked out of the box.

I am here to help users migrate to linux.
Feel free to tag me in linux threads.
Thanks

For me it is impossible to get it enter uefi boot menu to select iso image in usb to do a dual boot Linux windows install based on uefi
Any suggestions?
Hero book pro
Thanks

If I understand correctly, do you mean you cannot boot linux from usb?

You need to enter into the BIOS and keep usb drive as first boot property priority.
Idk how to enter into bios on your device.

Yes.
Finally I succeeded in setting up a dual boot system.

The only way is setting it fixed in bios

Telling windows to restart from ext device with uefi boot does not work.

After booting into Linux setup usb and installing it, then one must put Linux uefi boot as first boot device, in order to have grub starting first and letting you choose between Linux and windows 10

Regards,

Luca

1 Like

Yes the new bios leans more towards the Microsoft way. That’s why they have a windows boot sequence as default.

Good to hear that you have solved your issue. I feel herobox is an amazing device to work as linux device as you can do so many things of linux other than just normal browsing and watching movies.

More power to linux.
Cheers.

hi, any version of linux i install does not work the touchpad and wifi.
on manjaro the touchpad works but the problem of wifi remains

You need linux-firmware package.

Are you using herobook?

Yes
I have tried with various distro, both elementary and deepin and I have the same problem

But user @rkl said that everything worked on the latest kernel.

Can you try upgrading to latest 5.5 lts kernel on manjaro?

I used the 5.4 kernel on deepin and the touchpad works but not the wifi. Checking there are no drivers and I was unable to install them in any way. By updating to 5.5 would I solve the problem?