Install Linux on LapBook Air 14

Hello at all,

my name’s is Angelo and I’m proud to have a CHUWI (a very good product), but I’ve an issue and I don’t know how I can solve it.

I’ve bought a LapBook Air 14 and I woul like to install a distro Linux (Mint), but if I change the option on the boot and try to run the Linux installation (from the USB key) on boot phase I see only a “_” (underscore caracter) on the upper left-side of the black screen. After different attemps (with more bios/UEFI setting, USB keys and software to make a bootable disk) I read on the Web that this is a know problem (for example, the situation is described at the link https://techtablets.com/forum/topic/how-to-get-linux-working-uefi-flash-needed/).

Under the forum I read that an user solve it with “isorespin.sh” script (https://linuxiumcomau.blogspot.com/2017/06/customizing-ubuntu-isos-documentation.html), but I tried without success and the solution talked about the possibility to lost many device’s driver (!!!)

How I can fix this issue in a “good” solution? Can I upgrade/downgrade the bios/UEFI to obtain the option “OS Select”?

I would like to preserve my Win10 installation on the primary disk and install Linux on the installed secondary MM2 disk.

Can you help me?

Many thanks,
Angelo

[SOLVED]
used similar a Sabino1943’s procedure (described in https://forum.chuwi.com/u/Sabino1943)
With the application Rufus, I used this settings for make a bootable USB key:
partition “MBR”, destination “BIOS or UEFI”, file system “NTFS (I’m not sure… could be FAT32) with cluster’s size 8K. After the USB key was ready I’ve add inside the path EFI/Boot the file “Bootia32.efi” (fretrieved from https://github.com/hirotakaster/baytail-bootia32.efi/raw/master/bootia32.efi).
I was reboot the CHUWI, open the BIOS and change the boot’s sequence in USB >> Disk1 >> Disk2. After a new reboot with the inserted USB key I was able to install Mint 19.2 in dual boot mode (Linux+Win10)

Please note: I did not change the file Grub.cfg

Bye