Installing new SSD in Herobook Pro

I have a Chuwi Herobook Pro and am trying to install a new larger SSD, a Crucial 1 TB SATA M.2. 2280 MGFF, MX500, serial interface Serial ATA III, this one here: 1TB Crucial MX500 M.2 2280 Serial ATA III Internal Solid State Drive . This has a part number:“CT1000MX500SSD4” and is described elsewhere as NGFF and not NVMe.

I have cloned the existing Herobook Pro SSD onto the new SSD, using Acronis New Image for Crucial and that seemed to go alright i.e. the software ended by saying it had cloned successfully and I can see the files, using a USB enclosure, on it and they seem all in order and OK.

But when I swap the SSD into the herobook pro it only boots to the BIOS and does not seem to recognise the SSD at all.

Any ideas?

Did you clone on another computer? If so, keep in mind that the HeroBook’s SSD slot is installed backwards and you must place the SSD by turning it over and inserting the SSD with the letters facing inward.

Many thanks for replying, I cloned it on the same computer alright.

I don’t think it can be inserted both ways anyway? I tried it both ways but only one way would fit.

By the way do you know why the BIOS mentions NVMe, is that just because the BIOS is somehow generic or does the Herobook Pro actually take NVMe SSD disks?

Sorry you are right, I can insert the SSD card two ways. If I install it with the large writing of 'Crucial" etched on the chip, facing outwards, which seems to be the front side, then it boots to the BIOS only and I get no recognition of the disk, nor will it launch windows. If I turn it around and have that writing facing inwards, then I get a brick, it just doesn’t turn on at all.

The BIOS is: “American Megatrends core version 5.13” and dated 26th March 2020. It has a separate section called “NVMe Configuration” but then says there is no such disk detected.

I am in! I double checked all that and found that under the security tab of the BIOS it did recognise the SSD, but still wouldn’t boot.

So somewhere in the boot order, or at least the last section across the top of the BIOS options, it had 3 options, something like boot to windows, with numbers that showed it was the new ssd, then a second option with the exact same details, and then the third option of booting to the recovery screen which was enabled. When I set the setting to the middle option, the second windows one, it worked and booted right up! (booting to the first option didn’t work either.)

Many thanks for your help anyway, I am just delighted this has worked. Now I think I will set a bigger Windows swap file, I wonder how…!

No, HeroBook Pro sólo soporta SSD M2 SATA NGFF

Thanks for sharing…