Is Larkbox Turbo Boost always ON?

I’ve read lots of posts about the thermal and fan issues. I noticed that my Larkbox runs at the ‘step up’ 2.4GHz frequency all the time - when I thought the processor should run at 1.8GHz, only stepping up to Turbo 2.4Ghz mode under load?

Other than that, I’m relatively pleased with the Larkbox - it runs Team Fortress 2 at 60fps which is impressive for such a small unit - but the thermal and fan issues do need to be addressed by Chuwi as soon as possible.

It’s on by default. You can turn it off in BIOS (Advanced, CPU Settings, Power Management).

1 Like

Thanks for that - which control in that BIOS view do you mean? None say “Turbo”…

(Advanced, CPU Settings, Power Management)

Did you miss this part of my reply? :slight_smile:
OK, let me draw you a picture…

First you go into Advanced tab, and choose CPU Configuration there:

Then you choose CPU Power Management there:

20201008_105442

And you’ll find…

Thanks for explaining, I’m not very good with computers

No problem! :slight_smile:

I have been using ThrottleStop 9.2 to better control the CPU frequency. While one cannot undervolt this CPU, one can be more aggressive with sliding down the CPU frequency with the power saving options.

Good Luck

1 Like

Wow, this is a very interesting program! :+1:

Thanks for sharing. :smile:

how about powermanagement from win10? in setings you can set low, balanced, high power and you can set CPU speed there

Sorry, noob here. Why would I want to turn off Turbo mode?

if you set lower cpu speed, it will produce lower heat and thus it should use build in fan for cooling less, but sadly this is not possible here, bcz fan start from 54 degree, and even on idle you cant get under this temperature, so fan will not go off :confused: