Keyboard problem

Just bought herobook and it won’t let me type the @ key it comes up with “ when I press shift on 2?

Make sure that you use english (united states) keyboard layout, other layouts may have not this symbol.

Hi There, I have the same problem, I’m not very techy so can you guide me through what I do to get the @ sign (on a MacBook pro at the moment hence why it worked here).
I have tried changing the keyboard settings to UK and US and using the shift key as you would on any other keyboard and its not working. Any advice would be greatly received.

Thanks
Gaby