Linux audio driver support for GemiBook Pro

I bought a GemiBook Pro a few days ago; I installed linux (Pop OS) and everything seems to be working fine. Unfortunately the audio device is recognized but there’s no support for it, so it’s not working. Apparently it’s a common problem many customers are facing, as you can see on this link ( ).

I ask you to provide drivers as soon as possible since your hardware has great potential and many other companies such as HP, AMD, Nvidia etc. are already providing their drivers for Linux operating system.

The only divers I could find, don’t know if it works.

PC Audio Codecs > High Definition Audio Codecs Software - REALTEK

How do I use it on Linux?

I don’t know, I run windows but maybe this is a place to start.

from my understanding and this discussion : Linux on Chuwi GemiBook the sound might work with linux 5.16 …

If you did like to install your Realtek audio driver you might go through it step-by-step online.

I think this points to Windows drivers, the original post is for Linux.

Don’t know if you’re problem is solved, but I found an article that points to the bios to activate audio. There is also some explanation about installing Realtek on mint. Maybe it can help in some way.