Linux distro on minibook x?

Hello, it is not recommended to install Linux, some drivers may not be available after installation, thank you

1 Like

Have you guys tried to run Linux on it?

I can live with minimal drivers, no sound, no accelerometer etc. is needed, only basic ones .

By the way, is Chuwi planning on launching a new version of Minibook X soon?

1 Like

Hello to all.
I’m also really interested to install Ubuntu in this beautiful machine, that I’m still waiting (ordered in Banggood)

Someone had success to installa Linux ?

1 Like

Could @ChuwiService test Linux in the Minibook X?
There are for sure lot of customers waiting for such Linux machine !!

1 Like

I too ordered one from Banggood, in March 30, still waiting for them to ship it. They are selling it out of stock…

It seems everywhere i read , that Fedora runs best on Chuwi machines, including the previous Minibook.
Hopefully the basic stuff will work.


Hi, I’ve had a Minibook X with Linux working.


almost works but some issues.

distro: Gentoo Linux
kernel: 5.17.6-gentoo-x86_64
Desktop Environment/WM: sway

  • Boot: works
  • USB: works
  • Screen Rotation: works with customization
  • Touch Screen: works
  • WiFi: works
  • Bluetooth: works
  • Camera: works
  • Keyboard: works but a issue
  • Touchpad: works but a issue
  • Power Management: works but some issue

Some comments

Screen rotation and calibrating touch screen

The screen of Minibook X is initially adjusted to portrait layout. You can fix it by adding a kernel parameter to your bootloader(grub, systemd-boot, etc)


On GUI environment (GNOME, KDE, sway and others) you may set screen rotation by each setting. Here is an example of sway($HOME/.config/sway/config)

output DSI-1 transform 90

In sway, you can adjust touch screen and stylus input by adding the parameter to sway config. But I don’t test both well (just works)

  input "10182:282:GXTP738:00_27C6:011A" {    
    map_to_output DSI-1                       
  input "10182:282:GXTP738:00_27C6:011A_Stylus" {    
    map_to_output DSI-1                       

WiFi & Bluetooth

Works well with the latest kernel and linux-firmware combination. It seems no trouble. Here is the output of dmesg of iwlwifi driver.

[   10.343107] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[   10.344889] Loading firmware: iwlwifi-7265D-29.ucode
[   10.349901] iwlwifi 0000:01:00.0: Found debug destination: EXTERNAL_DRAM
[   10.350108] iwlwifi 0000:01:00.0: Found debug configuration: 0
[   10.350650] iwlwifi 0000:01:00.0: loaded firmware version 29.4063824552.0 7265D-29.ucode op_mode iwlmvm
[   10.478392] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210
[   10.564629] iwlwifi 0000:01:00.0: Applying debug destination EXTERNAL_DRAM
[   10.596987] iwlwifi 0000:01:00.0: Allocated 0x00400000 bytes for firmware monitor.


No trouble. works with uvcvideo driver. Confirmed with Google meet on Chromium browser.


Works well but sometimes hang for a while, chattering. Maybe it occurs in overheated situation.


Works well but often hang for a while. Maybe it occurs in overheated situation. Using a bluetooth mouse reduce your stress significantly:)

Power Management

Charging is good both AC adapter(12V) port and USB-C port. I don’t test power management feature deeply, like power drain issue and others.

The shutdown and reboot doesn’t work well. The shutdown process is not completed in spite of executing shutdown(systemctl poweroff) command. The power LED remains on, the system remains powered. Reboot process isn’t ether. The system isn’t rebooted, stop at the same stage of shutdown(remains powered)

I hope @ChuwiService development team will fix it in the UEFI firmware.


Hi, I had almost the same experience experimenting with ubuntu 22.04, including the touchpad stopping working when the laptop is hot. The only difference is that sometimes it doesn’t suspend when the lid close.
There are driver issues with power management in Linux (I think). It overheats fast (even when idling), and then it gets slow.


Hi @jeg thank you for your feedback. Fortunately we can have the kind support from the drm-intel community. Finally the dpms off/on, suspend/resume, and shutdown/reboot issue has gone away with the patched drm-tip kernel on my environment. So nice. If you are interested in this, let’s see this issue on freedesktop gitlab

The keyboard chattering and mouse freeze issues haven’t been solved yet):
The power management feature issue isn’t fixed either.

1 Like

Wow, thank you, I’ll try the patch!

Hi all,

I tried the current Linux Mint, but these things do not work properly:

  • screen rotation is wrong, xrandr does not fix it
  • touchscreen function does not work
  • wifi does not work
  • depending on the kernel version USB ethernet works with kernel 5.4.0-x but not with 5.8.0-x and not with 5.10.x

I am still trying to get it running.

1 Like


What’s your desktop environment? (like Chinamon, Mate-desktop and others) It may not be the problem of Minibook X specific. If you use a wayland session, xrandr doesn’t work.

What’s the version of the kernel on Mint?
It’d be better to try the latest kernel (5.10.x seems a little bit older)

Touchscreen is working with i2c hid generic driver on my environment

[ 10.338372] input: GXTP738:00 27C6:011A Touchscreen as /devices/pci0000:00/0000:00:15.2/i2c_designware.2/i2c-2/i2c-GXTP738:00/0018:27C6:011A.0001/input/input8

About WiFi please check my previous post, especially the iwlwifi-7265D-29.ucode fimware is loaded successfully on your environment.

It may not be the problem of Minibook X specific. If it’s regression of the kernel of Linux of Mint, It would be better to raise a issue to the Linux Mint community.

1 Like

Hey there again,

just wanted to thank you for opening an issue on gitlab regarding the turning off the computer and having to force the shutdown. I updated to the new linux-5.19-rc0 and the patch is included as promised !

And i was wondering what temperatures you’re getting, doing mild work or watching HD video.

I never had a fanless laptop and it seems this jasper lake it has inside has a max Tjunction of 105ºC, which it seems pretty high, but it does bother a bit that sometimes it reaches 57ºC , the bottom temperature of the laptop gets pretty uncomfortable , not harmful but annoying. It doesn’t help that where i live its been 38ºC …

1 Like

Disable “Native ASPM” in the BIOS to fix this issue. And while you’re there, you could probably disable IME and cap CPU by temperature rather than power draw.

1 Like

The 5.19 really solved the shotdown issue, very good!
Regarding the temperature I had to change the default TLP mode to battery, otherwise (in performance mode) the CPU would reach 68ºC and the casing would get really hot too. Now it stays below 57ºC.
One last issue for me was the keyboard chattering / getting stuck. This can be solved by resetting the keyboard driver in a shell script and I have a small icon for it in the tray. Either you can unload and load again the atkbd kernel or if you have a built in module you just reset the device by:
echo -n “i8042” > /sys/bus/platform/drivers/i8042/unbind
echo -n “i8042” > /sys/bus/platform/drivers/i8042/bind

The keyboard will then work properly again.


Thank you for your suggestion. I’ve already get free from this issue by using kernel 5.19 :slight_smile:

Hi oloinhenderson,

are you successfully running linux on your minibook?

everything works amazingly, with the exception of keyboard and touchpad…

They randomly stop working and i have to run:
rmmod -f i2c_hid_acpi && modprobe i2c_hid_acpi

This completely takes the joy of using the machine… i tried changing xf86-input-libinput by xf86-input-evdev, the touchpad didn’t work (only the physical click) and eventually the keyboard also stopped working , similarly to when i was using libinput.

I wonder if more recent versions of BIOS address this…

1 Like

Did anyone tried if disabling power management for USB or i2c devices using powertop will fix the touchpad and keyboard issues? It seems to be worth a try at least.
Edit: Nope, it didn’t work for me :frowning:

I recommend a tweak for better power consumption and less heat. This is a good resource: CPU frequency scaling - ArchWiki
Mine was using the default driver - intel_pstate (cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver) and powersave (cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor) I decided to stick with it, and tune it for maximum power efficiency. Energy-perf bias was only at 6 (cat /sys/devices/system/cpu/cpu*/power/energy_perf_bias), so ballanced, but I want it at maximum power saving, so 15. I installed cpupowercreated a systemd service:sudo nano /usr/lib/systemd/system/cpupower_energy_bias.service`

Description=Switch system CPU into powersave mode

ExecStart=-cpupower set -b 15


Which will set the bias to 15 at each boot. I didn’t notice any difference in performance, I hope it is doing something at least.
If you wanted maximum power efficiency, you could switch to cpufreq scaling driver, and ondemand governor, which should give you much lower power draw but will also affect performance.

I have been trying to find a solution for this myself, but have not been able to. What’s weird is that this seems to be less of an issue when running Windows – or at least, with my limited testing after re-installing Windows on mine to try it out, I didn’t have the issue occur at all in the several hours I used it. I would’ve definitely had the issue pop up if I was running Linux for that same amount of time.

I have been wondering if there is something we can do to modify a kernel parameter to have things behave a bit more like they do under Windows, but so far my attempts have not yielded any positive results. None of the parameters I tried for the i8042 module have had any impact on this issue, either.

It’s such a shame, because I feel the same as you. It’s actually such a wonderful little device, and pretty much everything works perfectly under Linux except this keyboard issue, which is such a big issue it can’t be ignored or worked around (well, unless you use an external keyboard I suppose, but that defeats the purpose).

I really wish we can find a way to fix or avoid this issue…

Speaking of this; what BIOS version do you all have?

Mine shows (using dmidecode -t bios):

BIOS Revision: 5.19
Firmware Revision: 1.8