Linux distro on minibook x?

Speaking of this; what BIOS version do you all have?

Mine shows (using dmidecode -t bios):

(...)
BIOS Revision: 5.19
Firmware Revision: 1.8
BIOS Revision: 5.19
Firmware Revision: 1.8

I am on kernel 5.15 (Solus) and fortunately keyboard always works for me, only touchpad is a problem. But it is not that annoying for me, I have a dropdown terminal (Yakuake) I created an alias for sudo rmmod -f i2c_hid_acpi && sudo modprobe i2c_hid_acpi and each time it stops forking I pop down the terminal, type the alias name, and it works again. It is annoying, but still Minibook X is the least problematic Linux laptop I have ever owned, and I owned a lot of niche ones.
But it is really weird I am not getting the keyboard problems. Could it be that newer kernel introduced this problem? Because we are using the same firmware, really weird.
Edit: Today the keyboard stopped working for the first time for me. I need to figure out a way to execute a shortcut on the desktop as root, best if without a password, so I can reset keyboard using touchscreen

I’m sorry to hear that you’re having keyboard issues too, but in a way it’s “good” as it means the problem is very consistent among our various MiniBook X devices.

I am not sure if your specific desktop environment has this option available through its settings, but try looking for the option that disables the trackpad when you’re typing. If you turn off that option, you’ll most likely notice that the trackpad doesn’t get this problem anymore, as the issue is --as far as I know-- always caused by the keyboard getting a key “stuck.” I could be wrong though, but I’d love to hear if you’re able to try this to see if that solves the trackpad symptom at least.

1 Like

You were right, that really seems to be it!

Oh, and BTW, I found a really easy way to reset the keyboard only using touchscreen.
do sudo visudo and at the end add ALL ALL=NOPASSWD: /sbin/rmmod,/sbin/modprobe (first ALL can be your username for more safety).
This will allow for those commands to be run as root without putting in password.
Then I created a desktop shortcut that executes sudo rmmod -f i2c_hid_acpi && sudo modprobe i2c_hid_acpi.
And that is it, it certainly doesn’t fix the main issue, but makes the laptop more usable for now.
Just make sure you can easily navigate to it only using touchscreen.

Hello, everybody, how’s battery life on your distro of choice?

Considering to buy one myself and run Fedora 36.
If I understood correctly, most issues, except keyboard and trackpad, are fixed and are in latest kernel at this point, thanks to all the things done by u guys.

I think sleep is broken too, with the screen not waking up. Hibernation works perfectly though.
After tuning governor for power save I get comparable times as on Windows, but it varies from 3.5h with low backlight, to 2 with maximum brightness, which is not a lot.
The keyboard and touchpad are annoying but livble, but I don’t expect them to ever get fixed…
Oh, and BTW, is accelerometer working for you guys? And convertible mode too? On 5.15 neither works, keyboard is not disabled when in tablet mode.

1 Like

As Jacek mentioned, the keyboard issue is not resolved yet unfortunately.

One of two parts of sleep related problems mentioned above have been fixed, the second one is as of right now not yet tackled by Intel’s engineers. We’re waiting for them on that. In the mean time, you can rely on a lighter sleep mode (though battery drains actively with that mode), use Hibernation, or just turn off your computer. I used to have Hibernation enabled, but these days I just turn it off when I’m done for the moment. SSDs are nice and fast, so it’s pretty quick (and I can take care of software updates while I’m at it).

Great choice! I’m running Fedora 36 Silverblue on it myself. It’s a solid choice and GNOME looks gorgeous with this display, and because of GNOME’s menubar at the top, it actually ends up working really nicely with the MiniBook X’ in-display camera too :).

2 Likes

All the issues mentioned don’t bother me as much as battery life. Nowhere near the advertised “8h” “all day long”. That’s a real deal breaker.

Anyways, thank you for quick and detailed answers!
Have a sunny day!

I wonder if there are anyone who are still interested in this topic…

Just information. The issue of display comeback from suspend/resume(deep sleep) has been fixed by upstream intel drm driver development community[1]. This fix will be merged to mainline kernel in the future:)

[1] DSI display don't come back from resume (#6131) · Issues · drm / intel · GitLab

2 Likes

I’m running Manjaro with 6.1 and see hibernation working. S3 suspend does not yet bring back the screen to live, so it stays black.
But I have not yet experienced the touchpad issues (cursor freezes while buttons still work as with 5.17 kernels) nor the keyboard freeze issues.

2 Likes

Four months using Deepin (with hibernation) without any issues.

@jeg thats great! Can you also share some details as Deepin is not the reason you’re not having issues but the underlying kernel and settings.

What is the kernel you are running?
Hibernation works, but what about S3?
Did you never experience the touchpad issue?
Did you never experience the keyboard issue?
Did you change any settings?

Thanks in advance for the elaborate answer.

I have fixed the wrongly rotated screen with this udev file. Just save it as /lib/udev/hwdb.d/61-sensor-MiniBookX, make sure you have iio-sensor-proxy installed and with screen-autorotate installed and activated the screen rotates always correctly.

Hi, in Deepin you can choose between two kernels. I used the newer one, a hwe 5.18 kernel. The only things I changed in the settings app were screen rotation and hibernation. I also installed tlp. S3 I have not tested it as I use hibernation. I did not have problems with the touchpad or with the keyboard. Interestingly the Nreal glasses work (as a secondary screen) direct from the USB C port.
For context, before Deepin I was using Ubuntu 22.04 with some 5.19 release candidate kernel so that the computer would shutdown, I also used hibernation because of the suspension issue. In Ubuntu, I did not had the keyboard problem but had the touchpad freezing issue.

1 Like

keep in mind that the only real issue is “ctrl” key getting “stuck” , as by default the “block touchpad while typing” is active, this would cause the touchpad to be unresponsive. This was what caused the touchpad to “malfunction”

The “ctrl” getting stuck was happening to a lot of people, its a minor issue, and happens rarely

Sadly this is not true for many, as not just the ctrl key gets “stuck” but any other key can and will get stuck, too. This is the only thing that prevented me from being able to actually use the Minibook X under Linux, as I personally can live without S3 sleep.

I tried all kinds of things, even adding two special kinds of tape between the keyboard ribbon cable and battery, compiling my own Kernel with keyboard input timings tweaked, but sadly nothing ever helped solve the issue for me. It seems to require a fix on the firmware level, and is not something that can be handled on our end. At least for those of us who sadly got the issue, as it does seem like not everyone has it.

It’s mostly Ctrl for me but I’ve had Shift stuck as well once or twice. Seems to happen when I do three-key shortcuts like Ctrl-Shift-Tab or Ctrl-Fn-PgDn, but not always. It’s just enough to be annoying.

I recently watched this video by Ben Eater on how keyboards work. Seems like the issue could be tracked down with a scope but mine is pretty basic and doesn’t have binary decoding so I don’t think that’s something I want to go through manually :slight_smile: