Linux distro on minibook x?

I think mine does much better than that:

You can see it’s like 11% over 24 hours. I do sleep with no apps open, though, which might reduce the RAM power draw. EDIT: No it doesn’t, RAM power consumption isn’t based on how much it’s utilized.

My guess is probably TLP that suspends many devices as well.


My Ubuntu install didn’t work any longer so I tried to reinstall.

Long story short, I erased my disk and tried to install ubuntu 24.04 daily build march 2, 2024. It fails. Of course the daily build is in alpha phase.

So I installed Fedora. It works kind of out of the box. And I found out my SSD parameters using lshw

description: NVMe device
product: AirDisk 512GB SSD
vendor: MAXIO Technology (Hangzhou) Ltd.
physical id: 0
bus info: pci@0000:01:00.0
logical name: /dev/nvme0
version: SN12221
serial: NEF011R002897P110N
width: 64 bits
clock: 33MHz
capabilities: nvme nvm_express bus_master cap_list
configuration: driver=nvme latency=0 state=live
resources: irq:16 memory:80400000-80403fff

Up to now this SSD hasn’t failed at all in linux. It can be replaced by another SSD. On youtube there is a guy showing replacement by a Samsung 1TB SSD.

Cheers, Jaap

PS this little laptop is a nice toy to me. I have more laptops so I don’t depend on it for work. Don’t try this at home. :slight_smile:

Tried the latest daily build of Ubuntu 24.04 yesterday. In addition to all that worked, Bluetooth works now as well. Auto screen rotation is not (yet) supported.

While the installer was broken last week, I didn’t try it. Maybe in a couple of weeks.

Cheers, Jaap

1 Like

thx for all this info.

There is an interesting topic on this forum about screen rotation in linux: Auto screen rotation - accelerometer not working in Linux - #5 by chinu. It is about creating a file to make it work.

File to create:
Contents of the file:
sensor:modalias:acpi:[driver name]:dmi::svn[Manufacturer]:pn[Product Name]:
ACCEL_MOUNT_MATRIX=1, 0, 0; 0, 1, 0; 0, 0, 1
Variables of the file:
[driver name] use the command “udevadm info --export-db | grep iio”
[Manufacturer] use the command “dmidecode | grep Manufacturer”
[Product Name] use the command “dmidecode | grep Product”
The matrix is the default matrix and might have to be adapted.

After loading Ubuntu 24.04 (16 March 2024) on the Minibook, it appeared the driver is not available. I think that was already stated by @leledumbo. :wink:

Cheers, Jaap

PS before “ACCEL_MOUNT_MATRIX=1, 0, 0; 0, 1, 0; 0, 0, 1” you will need a space. I couldn’t get the Forum editor to start a sentence with a space…

After trying many Ubuntu 24.04 (beta) desktop flavors, I gave (temporarily) up on Ubuntu. Every single desktop flavor gave the same problem: randomly only half a screen visible with all grey horizontal stripes. Bluetooth is not stable at all. Then I installed KDE Fedora 39. Up to now everything seems to work fine except the accelerometer. KDE is a personal preference for a classic interface, and its support for fractional scaling.

Cheers, Jaap

PS to be crystal clear: this is about the MiniBook X N100.

thanks for keep updating this

Device is Chuwi Minibook X N100, fully functional in Windows 11.

Have had tried Ubuntu 23.10.1, 24.04 as of april, 16 - nothing worked even with hacky things. Rotated screen with video grub parameters seems to be always tearing, suspend does not work even in 6.8 kernel with all the parameters set in grub as one could find in this thread. And most of all - the fricking keyboard that just disables entirely after booting, which i could not wrap my head around. I cannot even find it in xinput nor libinput, it just disappears. But in BIOS it works. Will be trying debian next, but it is already quite depressing for me even as advanced user. If nothing works, will be trying to resell it on local market, as i dont want to be locked in windows only.

Debian 12 installer does not recognize WiFi module, Debian Testing does, but requires microcode for it to work.

UPD: was able to ignore microcode request and just proceed with installation. Your mileage may vary.

Manjaro XFCE with kernel 6.6.26, no screen issues as of now, but keyboard and touchpad still no worky. Touchscreen is mirrored though, so basically unusable.

Had to leave Debian testing due to being a pain in the ass to configure without shitload of bloatware - excuse me - recommended packages. Also, screen was glitching too. Actually i think that screen glitches only in gnome-based systems, or maybe debian-based?..

So, if someone willing to give a try with helping me revive this goddamn keyboard - i am willing to give all the info you may need here. This notebook is by far the best ive used so far in my life, but support… Actually, @ChuwiService, @ChuwiSpainSupport, is there any way you guys may help? Maybe BIOS issue? It is locked down, though, nothing i can change here.

Have you followed my notes? Many of them are distro neutral, some are Ubuntu (descendants) specific. That keyboard disabled after booting is something new, perhaps a new batch of MiniBook X N100? If you can use an external keyboard, please paste the output of sudo libinput list-devices and sudo dmesg | grep i8042.

Yeah, i actually did find your notes, but sadly there is no point in using them as they are more optional feature specific, and i dont even have a basic feature such as keyboard… Anyway, all the info i collected:

BIOS version: DNN20 v2.17 x64
BIOS build time: 09/22/2023 15:35:48
EC version: 0.15
EC build time: 08/24/2023 18:49:20
CPU: Intel N100
Total memory: 12GB @ 4800 MT/s
Storage: AirDisk 512GB SSD
Secure boot: OFF
Fast boot: OFF
Boot mode: tried both UEFI and LEGACY

All commands that i’ve run i attached as txt files with descriptive names. “sleep” part in some files was due to having external keyboard attached, so i ran sleep 5; sudo xinput instead, and detached external keyboard in between.

Have to say, that keyboard works right until pressing f10/enter in grub. So maybe something weird happens with ACPI devices, as i saw some errors about it.
Tried i8042 flags such as nomux, nopnp, dumbkbd, but nothing helped. Tried to blacklist some modules (i2c_hid_acpi, i8042, maybe something else), didnt help.
Actually got to the point that i got ACPI table and checked for PNP0303, but even with my mid-tier programmings skills, i couldnt figure out what is wrong here. So i would attach this too, if someone can understand that. (file is, couldnt attach original files due to weird extensions)
sleep-xinput-long.txt (7,2 КБ)
libinput.txt (5,9 КБ)
journalctl.txt (2,5 МБ)

New users could attach only 3 files at once, so here i am with another batch:
dmesg.txt (77,5 КБ)
dmesg-i8042.txt (1,7 КБ)
sleep-xinput.txt (1,0 КБ)

And last one, which is ACPI table. (321,7 КБ)

UPD: found something related to my case. 217336 – keyboard not working Asus TUF FA617NS

UPD: cat /sys/class/dmi/id/chassis_type returns 10. Which is of type “Notebook”, as it stands in this commit, which fixed some issues on other convertibles.

Other than event number and group assignment, our xinput and libinput output are identical, i.e. the keyboard is there, detected. There’s nothing in dmesg or journalctl either that may disable the keyboard. Just to be sure, can you xinput list-props <keyboard id>?

This could be out of our reach and needs kernel level fix as in the linked ASUS TUF keyboard issue.

1 Like

If its AT Translated Set 2 keyboard, then here it is:

Device 'AT Translated Set 2 keyboard':
	Device Enabled (178):	1
	Coordinate Transformation Matrix (180):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Rotation Angle (292):	0.000000
	libinput Rotation Angle Default (293):	0.000000
	libinput Send Events Modes Available (294):	1, 0
	libinput Send Events Mode Enabled (295):	0, 0
	libinput Send Events Mode Enabled Default (296):	0, 0
	Device Node (297):	"/dev/input/event5"
	Device Product ID (298):	1, 1

UPD: went as far as patching intel-vbtn module to support INT33D3 sensor and adding our notebook to exceptions, but still does not work, resulting in such kernel message:

[ 5494.290456] intel_vbtn: bad vermagic: kernel tainted.
[ 5494.290465] Disabling lock debugging due to kernel taint
[ 5494.290579] intel_vbtn: loading out-of-tree module taints kernel.
[ 5494.290583] intel_vbtn: module verification failed: signature and/or required key missing - tainting kernel
[ 5494.291779] intel-vbtn INT33D3:00: failed to read Intel Virtual Button driver

Just in case, applied recommended defaults in BIOS via F9 key. Still does not work.

UPD2: Funny enough, acpi-listen does not show ANY events going. Huh. Same with libinput debug or whatever it is, it shows only touchscreen events.

UPD3: Even funnier, if you happened to hold any keys during boot, keyboard will be backlit even after boot, it wasnt before. Keypresses are still dont work, though.

You don’t want to give Fedora 39 a try?

I was quite surprised it worked out of the box, while Ubuntu 23.10 and 24.04 beta did not work very well. Haven’t tested Manjaro, no intention either.

Will give a try, but what desktop environment you are using? Also, did you need to do something in order to keyboard to function? Such as libinput quircks file?

I use KDE. Everything except screen rotation worked out of the box. No quirks.

The minibook I have:

BIOS version: DNN20 v2.13 x64
BIOS build time: 09/05/2023 13:50:58
EC version: 0.15
EC build time: 08/24/2023 18:49:20
CPU: Intel N100
Total memory: 12GB @ 4800 MT/s
Storage: AirDisk 512GB SSD
Secure boot: ON
Fast boot: ON
Boot mode: UEFI

Unfortunately, my minibook does not cooperate and still shows screen glitches and keyboard is not working even after installing Fedora 39. I suspect it is due to having newer BIOS, v2.17. If only @ChuwiService gave us easier way to acquire all BIOS versions, like gigabyte does for my AERO KE4… Ahh, dreams.
Anyway, @jaap, can you please dump your ROM so i could use official chuwi tool to flash it, instead of, for example, v2.19?

Fedora 40 GNOME works just fine except for screen rotation which I’m trying to solve.

I made this to collaborate on better Linux support GitHub - sonnyp/linux-minibook-x: Linux for the Chuwi MiniBook X 2023 / N100 - might be easier than in a single thread here.

Feel free to use discussions.