RZBOX - Neither WIndows nor Ubuntu can be installed

Tried hundreds of times to install Windows 10 and Windows 11 with the reinstallation files sent by Chuwi support team, but every time I got an error while the installation was copying the image file into the drive.

Just to cross-check I tried installing Ubuntu and even that could not be installed. Got an error at the partitioning stage.

After spending many hours and significant research I think it is something to do with BIOS as I read that some AMD bios were not allowing copying of big files from a USB device.

I almost spent a week on this thing and could not figure out the issue. Very frustrating.

1 Like

The issue is narrowed down to:

“The system cannot find the drive specified” - Win11
“The system cannot find the path specified” - Win10

This repeats despite doing the
diskpart
list disk
Select Disk " "
clean
exit
startnet.cmd

Is this a hardware issue or BIOS issue? Someone, please help.

1 Like

If you have a 1tb ssd, it doesn’t work, i have bought a 500gb ssd, and now works. i have already written to support, to ask a bios update

1 Like

Hi, Matteo
I can’t install Windows on Samsung 970 EVO plus (I’ve try with 1TB and 500GB size).
Which SSD have you used?
Thanks
Giovanni

Hi Giovanni,
I’ve used this one

Thank you so much for the quick answer.
Was the 1TB SSD also from the same brand? As already mentioned I bought 2 Samsung 970 EVO SSDs (1TB+500GB) but I can’t get them to work with the RZBOX.
Thank you.
Giovanni

You’re welcome. 1tb ssd was the same than you, Samsung 970 evo

I wonder, can Windows not be installed the normal way with
https://www.microsoft.com/software-download/windows11

Hi Eldijomo,
I think there is an incompatibility

If an computer does not install with normal win11 Ms software than I wold return for warranty.

The RZBox seems to have issues with NVME SSDs that have higher transfer rates.

I tried a bunch of SSDs from Inland and Samsung.

SSDs with read speeds over 2400 and write speeds over 1600 seems to cause the SSD to vanish during install. In windows this will cause the install to fail with an error that makes you think the USB drive is broken on Linux the install fails and the SSD doesn’t exist or is non responsive.

I tried the faster Inland and Samsung SSDs that have 3000 / 2900 read /write and had this issue.
I tried SATA M.2 SSDs and those worked but they max out at 500 / 500
Eventually i stumbled on NVME SSDs that has speeds of 2400/1600 and those worked. I currently have 2 x 1TB in a Raid 0 in my RZBOX. Windows installed without issue.

Not sure if this can be fixed with a BIOS update or if it is just a limitation of the RZBox that should be documented to prevent confusion.

2 Likes

I second your observations. Chuwi must address this as suggested in your post.

1 Like

just to confirm: in my case Samsung 970evo+ ist not working/lets my system crash after seconds installed in either of the 2 ports